summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorValentin Ignatev <valentignatev@gmail.com>2020-02-02 02:37:06 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-02-27 20:59:48 +0200
commit07a7f722e6d7e71cb0eac8a6f75d1e8e539195a0 (patch)
treeba52f31a96442bab1f55ab99319d297ed719f8e2
parent895bb1f7d24d41dde90de185abd9d37856dc7f43 (diff)
downloadpatches-07a7f722e6d7e71cb0eac8a6f75d1e8e539195a0.tar
patches-07a7f722e6d7e71cb0eac8a6f75d1e8e539195a0.tar.gz
gnu: Add rust-wayland-protocols-0.23.
* gnu/packages/crates-io.scm (rust-wayland-protocols-0.23): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/crates-io.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 8f105ba1a5..25497bbb44 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -19710,6 +19710,34 @@ the wayland protocol, client side.")
"Common types and structures used by wayland-client and wayland-server.")
(license license:expat)))
+(define-public rust-wayland-protocols-0.23
+ (package
+ (name "rust-wayland-protocols")
+ (version "0.23.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "wayland-protocols" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1ygwbzqlnks5xzafka3c8ag6k92g2h6ygj2xsmvjfx2n6rj8dhkc"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-bitflags" ,rust-bitflags-1)
+ ("rust-wayland-client" ,rust-wayland-client-0.23)
+ ("rust-wayland-commons" ,rust-wayland-commons-0.23)
+ ("rust-wayland-server" ,rust-wayland-server-0.23)
+ ("rust-wayland-scanner" ,rust-wayland-scanner-0.23))))
+ (home-page "https://github.com/smithay/wayland-rs")
+ (synopsis
+ "Generated API for the officials wayland protocol extensions")
+ (description
+ "Generated API for the officials wayland protocol extensions.")
+ (license license:expat)))
+
(define-public rust-wayland-scanner-0.23
(package
(name "rust-wayland-scanner")