summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrice Waegeneire <brice@waegenei.re>2020-02-16 22:28:32 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2020-02-27 14:31:26 +0100
commit052847422341e580f79bda8384f03746baa5b5e2 (patch)
tree074ad21e3a4fc1f48190ae4413403300bf359819
parentca839f3c1867903d217a2a61ebcc7dfb250b5e5f (diff)
downloadpatches-052847422341e580f79bda8384f03746baa5b5e2.tar
patches-052847422341e580f79bda8384f03746baa5b5e2.tar.gz
gnu: Remove kicad-library.
* gnu/packages/engineering.scm (kicad-library): Remove variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
-rw-r--r--gnu/packages/engineering.scm62
1 files changed, 0 insertions, 62 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 28a10bb90e..00971cd0fd 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -865,68 +865,6 @@ perform specific functions, for example, pcbnew (Editing PCB), eeschema (editing
electrical diagrams), gerbview (viewing Gerber files) and others.")
(license license:gpl3+)))
-(define-public kicad-library
- (let ((version "4.0.7"))
- (package
- (name "kicad-library")
- (version version)
- (source
- (origin
- (method url-fetch)
- (uri (string-append
- "https://kicad-downloads.s3.cern.ch/libraries/kicad-library-"
- version ".tar.gz"))
- (sha256
- (base32 "1azb7v1y3l6j329r9gg7f4zlg0wz8nh4s4i5i0l9s4yh9r6i9zmv"))))
- (build-system cmake-build-system)
- (arguments
- `(#:out-of-source? #t
- #:tests? #f ; no tests
- #:phases
- (modify-phases %standard-phases
- (add-after 'install 'install-footprints ; from footprints tarball
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (invoke "tar" "xvf"
- (assoc-ref inputs "kicad-footprints")
- "-C" (string-append (assoc-ref outputs "out")
- "/share/kicad/modules")
- "--strip-components=1")))
- ;; We change the default global footprint file, which is generated if
- ;; it doesn't exist in user's home directory, from the one using the
- ;; github plugin, to the one using the KISYSMOD environment path.
- (add-after 'install-footprints 'use-pretty-footprint-table
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (template-dir (string-append out "/share/kicad/template"))
- (fp-lib-table (string-append template-dir "/fp-lib-table")))
- (delete-file fp-lib-table)
- (copy-file (string-append fp-lib-table ".for-pretty")
- fp-lib-table))
- #t)))))
- (native-search-paths
- (list (search-path-specification
- (variable "KISYSMOD") ; footprint path
- (files '("share/kicad/modules")))
- (search-path-specification
- (variable "KISYS3DMOD") ; 3D model path
- (files '("share/kicad/modules/packages3d")))))
- ;; Kicad distributes footprints in a separate tarball.
- (native-inputs
- `(("kicad-footprints"
- ,(origin
- (method url-fetch)
- (uri (string-append
- "http://downloads.kicad-pcb.org/libraries/kicad-footprints-"
- version ".tar.gz"))
- (sha256
- (base32
- "08qrz5zzsb5127jlnv24j0sgiryd5nqwg3lfnwi8j9a25agqk13j"))))))
- (home-page "https://kicad-pcb.org/")
- (synopsis "Libraries for kicad")
- (description "This package provides Kicad component, footprint and 3D
-render model libraries.")
- (license license:lgpl2.0+))))
-
(define-public kicad-symbols
(package
(name "kicad-symbols")