summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEvan Straw <evan.straw99@gmail.com>2020-02-25 11:27:16 -0800
committerMarius Bakke <mbakke@fastmail.com>2020-02-26 21:52:48 +0100
commite524b57740cd6ac51613b5072b6e43b4c5aab281 (patch)
treef5cf83be49237efb02ceff352fe5bb68f0a4c8f1
parentcae3b3774ea9905bbf6a7299c3cd964cfa48a705 (diff)
downloadpatches-e524b57740cd6ac51613b5072b6e43b4c5aab281.tar
patches-e524b57740cd6ac51613b5072b6e43b4c5aab281.tar.gz
gnu: awscli: Update to 1.18.6.
* gnu/packages/python-web.scm (awscli): Update to 1.18.6. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/python-web.scm73
1 files changed, 37 insertions, 36 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index f9981454fb..310fec4edf 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -32,6 +32,7 @@
;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
+;;; Copyright © 2020 Evan Straw <evan.straw99@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1600,43 +1601,43 @@ supports url redirection and retries, and also gzip and deflate decoding.")
(define-public awscli
(package
- (name "awscli")
- (version "1.14.41")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri name version))
- (sha256
- (base32
- "0sispclx263lybbk19zp1n9yhg8xxx4jddypzgi24vpjaqnsbwlc"))))
- (build-system python-build-system)
- (arguments
- ;; FIXME: The 'pypi' release does not contain tests.
- '(#:tests? #f
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-reference-to-groff
- (lambda _
- (substitute* "awscli/help.py"
- (("if not self._exists_on_path\\('groff'\\):") "")
- (("raise ExecutableNotFoundError\\('groff'\\)") "")
- (("cmdline = \\['groff'")
- (string-append "cmdline = ['" (which "groff") "'")))
- #t)))))
- (propagated-inputs
- `(("python-colorama" ,python-colorama)
- ("python-botocore" ,python-botocore)
- ("python-s3transfer" ,python-s3transfer)
- ("python-docutils" ,python-docutils)
- ("python-pyyaml" ,python-pyyaml)
- ("python-rsa" ,python-rsa)))
- (inputs
- `(("groff" ,groff)))
- (home-page "https://aws.amazon.com/cli/")
- (synopsis "Command line client for AWS")
- (description "AWS CLI provides a unified command line interface to the
+ (name "awscli")
+ (version "1.18.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri name version))
+ (sha256
+ (base32
+ "0p479mfs9r0m82a217pap8156ijwvhv6r3kqa4k267gd05wgvygm"))))
+ (build-system python-build-system)
+ (arguments
+ ;; FIXME: The 'pypi' release does not contain tests.
+ '(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-reference-to-groff
+ (lambda _
+ (substitute* "awscli/help.py"
+ (("if not self._exists_on_path\\('groff'\\):") "")
+ (("raise ExecutableNotFoundError\\('groff'\\)") "")
+ (("cmdline = \\['groff'")
+ (string-append "cmdline = ['" (which "groff") "'")))
+ #t)))))
+ (propagated-inputs
+ `(("python-colorama" ,python-colorama)
+ ("python-botocore" ,python-botocore)
+ ("python-s3transfer" ,python-s3transfer)
+ ("python-docutils" ,python-docutils)
+ ("python-pyyaml" ,python-pyyaml)
+ ("python-rsa" ,python-rsa)))
+ (native-inputs
+ `(("groff" ,groff)))
+ (home-page "https://aws.amazon.com/cli/")
+ (synopsis "Command line client for AWS")
+ (description "AWS CLI provides a unified command line interface to the
Amazon Web Services (AWS) API.")
- (license license:asl2.0)))
+ (license license:asl2.0)))
(define-public python-wsgiproxy2
(package