summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Hill <jackhill@jackhill.us>2020-02-25 14:16:07 -0500
committerMarius Bakke <mbakke@fastmail.com>2020-02-26 21:52:48 +0100
commitcae3b3774ea9905bbf6a7299c3cd964cfa48a705 (patch)
treef63a22e93d155fd40bdaaf1040443c601c04dc62
parent233332c2e9cb76927dd7573b24bd7cdf7afca993 (diff)
downloadpatches-cae3b3774ea9905bbf6a7299c3cd964cfa48a705.tar
patches-cae3b3774ea9905bbf6a7299c3cd964cfa48a705.tar.gz
gnu: vim-full: Describe differences from vim.
* gnu/packages/vim.scm (vim-full)[description]: New field. Explain what vim-full provides over vim. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/vim.scm19
1 files changed, 18 insertions, 1 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 67f245b26d..a94a677b25 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2019 HiPhish <hiphish@posteo.de>
;;; Copyright © 2019 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2019, 2020 Jakub Kądziołka <kuba@kadziolka.net>
+;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -131,6 +132,8 @@
("tzdata" ,tzdata-for-tests)))
(home-page "https://www.vim.org/")
(synopsis "Text editor based on vi")
+ ;; The description shares language with the vim-full package. When making
+ ;; changes, check if the other description also needs to be updated.
(description
"Vim is a highly configurable text editor built to enable efficient text
editing. It is an improved version of the vi editor distributed with most UNIX
@@ -254,7 +257,21 @@ with the editor vim.")))
("python-3" ,python)
("ruby" ,ruby)
("tcl" ,tcl)
- ,@(package-inputs vim)))))
+ ,@(package-inputs vim)))
+ ;; The description shares language with the vim package. When making
+ ;; changes, check if the other description also needs to be updated.
+ (description "Vim is a highly configurable text editor built to enable efficient text
+editing. It is an improved version of the vi editor distributed with most UNIX
+systems.
+
+Vim is often called a \"programmer's editor,\" and so useful for programming
+that many consider it an entire IDE. It's not just for programmers, though.
+Vim is perfect for all kinds of text editing, from composing email to editing
+configuration files.
+
+This package provides a version of Vim with many optional features enabled.
+It includes a graphical interface, @command{gvim}, and support for plugins
+written in the Python 3, Perl, Ruby, Tcl, and Lua programming languages.")))
(define-public vim-neocomplete
(package