summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-09 18:09:07 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-09 18:11:20 +0100
commitbf770d92402fbdfe1ea601db1d97bd888571b7e2 (patch)
tree33e71a92ecec5e258f18a1fe158eb8fb0b7641aa
parent151965fab41be41e798eceb85694a2030f0d127a (diff)
downloadpatches-bf770d92402fbdfe1ea601db1d97bd888571b7e2.tar
patches-bf770d92402fbdfe1ea601db1d97bd888571b7e2.tar.gz
gnu: r-metap: Update to 1.2.
* gnu/packages/cran.scm (r-metap): Move this from here... * gnu/packages/bioconductor.scm (r-metap): ...to here and update to 1.2. [propagated-inputs]: Add r-mutoss and r-tfisher.
-rw-r--r--gnu/packages/bioconductor.scm29
-rw-r--r--gnu/packages/cran.scm25
2 files changed, 29 insertions, 25 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 733d4ec956..e584a7bced 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -3072,6 +3072,35 @@ are standardized and usable by the accompanying mutossGUI package.")
;; Any version of the GPL.
(license (list license:gpl2+ license:gpl3+))))
+;; This is a CRAN package, but it depends on mutoss, which depends on multtest
+;; from Bioconductor, so we put it here.
+(define-public r-metap
+ (package
+ (name "r-metap")
+ (version "1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "metap" version))
+ (sha256
+ (base32
+ "0pfbcixjrzx81l9wqhlp55khg9k63zf8pvg2n39c19akr4ppzhvf"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-lattice" ,r-lattice)
+ ("r-mutoss" ,r-mutoss)
+ ("r-rdpack" ,r-rdpack)
+ ("r-tfisher" ,r-tfisher)))
+ (home-page "http://www.dewey.myzen.co.uk/meta/meta.html")
+ (synopsis "Meta-analysis of significance values")
+ (description
+ "The canonical way to perform meta-analysis involves using effect sizes.
+When they are not available this package provides a number of methods for
+meta-analysis of significance values including the methods of Edgington,
+Fisher, Stouffer, Tippett, and Wilkinson; a number of data-sets to replicate
+published results; and a routine for graphical display.")
+ (license license:gpl2)))
+
(define-public r-triform
(package
(name "r-triform")
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 8ece8476d3..11d254001f 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -4123,31 +4123,6 @@ functions to compile LaTeX documents, and install missing LaTeX packages
automatically.")
(license license:expat)))
-(define-public r-metap
- (package
- (name "r-metap")
- (version "1.1")
- (source
- (origin
- (method url-fetch)
- (uri (cran-uri "metap" version))
- (sha256
- (base32
- "10kv7z8pik5iy374h399vws0ldf41y2nczlwh8axqf9dcwl084i0"))))
- (build-system r-build-system)
- (propagated-inputs
- `(("r-lattice" ,r-lattice)
- ("r-rdpack" ,r-rdpack)))
- (home-page "http://www.dewey.myzen.co.uk/meta/meta.html")
- (synopsis "Meta-analysis of significance values")
- (description
- "The canonical way to perform meta-analysis involves using effect sizes.
-When they are not available this package provides a number of methods for
-meta-analysis of significance values including the methods of Edgington,
-Fisher, Stouffer, Tippett, and Wilkinson; a number of data-sets to replicate
-published results; and a routine for graphical display.")
- (license license:gpl2)))
-
(define-public r-network
(package
(name "r-network")