summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-02-26 16:15:47 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-02-26 21:52:46 +0100
commitbbd804b29bbb9bc7739688bca192eb83d0edb882 (patch)
tree49a1e8660852b3e845abaa680ebf8376587cdbf0
parentae9cfc647daea456823adecba28021896b51407e (diff)
downloadpatches-bbd804b29bbb9bc7739688bca192eb83d0edb882.tar
patches-bbd804b29bbb9bc7739688bca192eb83d0edb882.tar.gz
gnu: nghttp2: Add version 1.40.0.
* gnu/packages/web.scm (nghttp2-1.40): New public variable.
-rw-r--r--gnu/packages/web.scm16
1 files changed, 15 insertions, 1 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 4976059203..2be3dfefe4 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -19,7 +19,7 @@
;;; Copyright © 2016, 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2016 Bake Timmons <b3timmons@speedymail.org>
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
-;;; Copyright © 2017, 2018 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2017, 2018, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2017 Petter <petter@mykolab.ch>
;;; Copyright © 2017 Pierre Langlois <pierre.langlois@gmx.com>
@@ -7025,6 +7025,20 @@ compressed JSON header blocks.
(base32
"12yfsjghbaypp4w964d45ih9vs38g6anih80wbsflaxx192idlm2"))))))
+;; 'Node' requires this newer version, to be removed on the next rebuild cycle.
+(define-public nghttp2-1.40
+ (package/inherit
+ nghttp2
+ (version "1.40.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/nghttp2/nghttp2/"
+ "releases/download/v" version "/"
+ "nghttp2-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0wwhwv7cvi1vxpdjwvg0kpa4jzhszclpnwrwfcw728zz53a47z09"))))))
+
(define-public hpcguix-web
(let ((commit "f39c90b35e99e4122b0866ec4337020d61c81508")
(revision "4"))