summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-02-26 17:22:22 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-02-26 21:52:47 +0100
commit5cfc6a88e9fbb9f34855ebd43264266b0201ce50 (patch)
treeca932a02b718473b3bf52a10a48b433698681b29
parent458c3ff552005cbf69ed4a1daee3529214ae73cf (diff)
downloadpatches-5cfc6a88e9fbb9f34855ebd43264266b0201ce50.tar
patches-5cfc6a88e9fbb9f34855ebd43264266b0201ce50.tar.gz
gnu: node: Disable failing tests on armhf-linux.
* gnu/packages/node.scm (node)[arguments]: When building on armhf-linux, disable several zlib tests.
-rw-r--r--gnu/packages/node.scm17
1 files changed, 15 insertions, 2 deletions
diff --git a/gnu/packages/node.scm b/gnu/packages/node.scm
index 296a5e1980..eb8c83d831 100644
--- a/gnu/packages/node.scm
+++ b/gnu/packages/node.scm
@@ -74,8 +74,7 @@
#t))))
(build-system gnu-build-system)
(arguments
- ;; TODO: Purge the bundled copies from the source.
- '(#:configure-flags '("--shared-cares"
+ `(#:configure-flags '("--shared-cares"
"--shared-http-parser"
"--shared-libuv"
"--shared-nghttp2"
@@ -121,6 +120,20 @@
;; https://github.com/nodejs/node/issues/31213
(delete-file "test/parallel/test-net-listen-after-destroying-stdin.js")
+ ;; FIXME: These tests fail on armhf-linux:
+ ;; https://github.com/nodejs/node/issues/31970
+ ,@(if (string-prefix? "arm" (%current-system))
+ '((for-each delete-file
+ '("test/parallel/test-zlib.js"
+ "test/parallel/test-zlib-brotli.js"
+ "test/parallel/test-zlib-brotli-flush.js"
+ "test/parallel/test-zlib-brotli-from-brotli.js"
+ "test/parallel/test-zlib-brotli-from-string.js"
+ "test/parallel/test-zlib-convenience-methods.js"
+ "test/parallel/test-zlib-random-byte-pipes.js"
+ "test/parallel/test-zlib-write-after-flush.js")))
+ '())
+
;; These tests have an expiry date: they depend on the validity of
;; TLS certificates that are bundled with the source. We want this
;; package to be reproducible forever, so remove those.