summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVincent Legoll <vincent.legoll@gmail.com>2020-02-22 00:37:23 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-02-26 21:52:48 +0100
commit176dd26b38410b371a6283813698d6d7a419ada3 (patch)
tree223b180f3638f0a4a04dc8cf9c4703ceb7ad99f0
parentb18d3c526834a58d71566be6f0f0453dc55881e2 (diff)
downloadpatches-176dd26b38410b371a6283813698d6d7a419ada3.tar
patches-176dd26b38410b371a6283813698d6d7a419ada3.tar.gz
gnu: benchmark: Add bonnie++.
* gnu/packages/benchmark.scm (bonnie++): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/benchmark.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/benchmark.scm b/gnu/packages/benchmark.scm
index 602681ac86..9ae30eefc8 100644
--- a/gnu/packages/benchmark.scm
+++ b/gnu/packages/benchmark.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2019 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2019 Gábor Boskovits <boskovits@gmail.com>
;;; Copyright © 2019 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -35,6 +36,7 @@
#:use-module (gnu packages linux)
#:use-module (gnu packages maths)
#:use-module (gnu packages mpi)
+ #:use-module (gnu packages perl)
#:use-module (gnu packages python)
#:use-module (gnu packages python-science)
#:use-module (gnu packages python-xyz)
@@ -231,3 +233,28 @@ This can give a much better understanding of the command's performance.")
"Benchmark is a library to benchmark code snippets,
similar to unit tests.")
(license license:asl2.0)))
+
+(define-public bonnie++
+ (package
+ (name "bonnie++")
+ (version "1.98")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://www.coker.com.au/bonnie++/bonnie++-"
+ version ".tgz"))
+ (sha256
+ (base32
+ "010bmlmi0nrlp3aq7p624sfaj5a65lswnyyxk3cnz1bqig0cn2vf"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("perl" ,perl)))
+ (arguments '(#:tests? #f)) ; there are no tests
+ (home-page "https://doc.coker.com.au/projects/bonnie/")
+ (synopsis "Hard drive and file system benchmark suite")
+ (description
+ "Bonnie++ is a benchmark suite that is aimed at performing a number of
+simple tests of hard drive and file system performance. Bonnie++ allows you to
+benchmark how your file systems perform with respect to data read and write
+speed, the number of seeks that can be performed per second, and the number of
+file metadata operations that can be performed per second.")
+ (license license:gpl2))) ;GPL 2 only, see copyright.txt