summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-02-26 14:05:36 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-02-26 14:07:32 +0100
commit146430ea0e0008ff91972f944920dfa01d1ab360 (patch)
tree41ba5aa121e00cca752bd2e298349b9751f33435
parent920757566996f6a22b14074b92acd4bdf29a47cd (diff)
downloadpatches-146430ea0e0008ff91972f944920dfa01d1ab360.tar
patches-146430ea0e0008ff91972f944920dfa01d1ab360.tar.gz
gnu: proteinortho: Update to 6.0.14.
* gnu/packages/bioinformatics.scm (proteinortho): Update to 6.0.14. [source]: Fetch from git; remove pre-built scripts. [arguments]: Set make-flags; update wrap-programs phase to wrap all scripts. [inputs]: Add guile-3.0, diamond, python-wrapper, lapack, and openblas; remove python-2. [native-inputs]: Add which. [license]: Update to GPLv3+
-rw-r--r--gnu/packages/bioinformatics.scm52
1 files changed, 33 insertions, 19 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 546be38ab0..8ed13b22e5 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -4921,20 +4921,26 @@ predicts the locations of structural units in the sequences.")
(define-public proteinortho
(package
(name "proteinortho")
- (version "5.16b")
- (source
- (origin
- (method url-fetch)
- (uri
- (string-append
- "http://www.bioinf.uni-leipzig.de/Software/proteinortho/proteinortho_v"
- version "_src.tar.gz"))
- (sha256
- (base32
- "1wl0dawpssqwfjvr651r4wlww8hhjin8nba6xh71ks7sbypx886j"))))
+ (version "6.0.14")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/paulklemm_PHD/proteinortho.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0pmy617zy2z2w6hjqxjhf3rzikf5n3mpia80ysq8233vfr7wrzff"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; remove pre-built scripts
+ (delete-file-recursively "src/BUILD/")
+ #t))))
(build-system gnu-build-system)
(arguments
`(#:test-target "test"
+ #:make-flags '("CC=gcc")
#:phases
(modify-phases %standard-phases
(replace 'configure
@@ -4952,15 +4958,23 @@ predicts the locations of structural units in the sequences.")
#t))
(add-after 'install 'wrap-programs
(lambda* (#:key inputs outputs #:allow-other-keys)
- (let* ((path (getenv "PATH"))
- (out (assoc-ref outputs "out"))
- (binary (string-append out "/bin/proteinortho5.pl")))
- (wrap-program binary `("PATH" ":" prefix (,path))))
+ (let ((path (getenv "PATH"))
+ (out (assoc-ref outputs "out")))
+ (for-each (lambda (script)
+ (wrap-script script `("PATH" ":" prefix (,path))))
+ (cons (string-append out "/bin/proteinortho")
+ (find-files out "\\.(pl|py)$"))))
#t)))))
(inputs
- `(("perl" ,perl)
- ("python" ,python-2)
- ("blast+" ,blast+)))
+ `(("guile" ,guile-3.0) ; for wrap-script
+ ("diamond" ,diamond)
+ ("perl" ,perl)
+ ("python" ,python-wrapper)
+ ("blast+" ,blast+)
+ ("lapack" ,lapack)
+ ("openblas" ,openblas)))
+ (native-inputs
+ `(("which" ,which)))
(home-page "http://www.bioinf.uni-leipzig.de/Software/proteinortho")
(synopsis "Detect orthologous genes across species")
(description
@@ -4968,7 +4982,7 @@ predicts the locations of structural units in the sequences.")
species. For doing so, it compares similarities of given gene sequences and
clusters them to find significant groups. The algorithm was designed to handle
large-scale data and can be applied to hundreds of species at once.")
- (license license:gpl2+)))
+ (license license:gpl3+)))
(define-public pyicoteo
(package