summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-01-13 12:38:17 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-01-13 12:44:03 +0200
commitd691e966579398d6dae7a7f50fbe5acd6041989d (patch)
tree1e44304b5cd49cd7e172d2ee8bdce15315900e36
parent675e7bba3e4f26d53ecb98125618aa5c250fd9fe (diff)
downloadpatches-d691e966579398d6dae7a7f50fbe5acd6041989d.tar
patches-d691e966579398d6dae7a7f50fbe5acd6041989d.tar.gz
gnu: conda: Use 'invoke'.
* gnu/packages/package-management.scm (conda)[arguments]: Use 'invoke'.
-rw-r--r--gnu/packages/package-management.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index a044397620..2d88381457 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -786,7 +786,7 @@ This package provides Conda as a library.")
;; application form, rather than the default, library form.
;; With this, we are able to run commands like `conda --help`
;; directly on the command line
- (zero? (system* "python" "utils/setup-testing.py" "build_py"))))
+ (invoke "python" "utils/setup-testing.py" "build_py")))
(replace 'install
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -802,8 +802,8 @@ This package provides Conda as a library.")
;; And it aborts if the directory doesn't exist.
(mkdir-p target)
- (zero? (system* "python" "utils/setup-testing.py" "install"
- (string-append "--prefix=" out))))))
+ (invoke "python" "utils/setup-testing.py" "install"
+ (string-append "--prefix=" out)))))
;; The "activate" and "deactivate" scripts don't need wrapping.
;; They also break when they are renamed.
(add-after 'wrap 'undo-wrap