summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-02-25 22:08:38 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-02-25 22:49:20 +0100
commitd2ebdb795d00ae57199491af678ba97a905abc55 (patch)
tree6ded2cf79d132b1b442faf6cc2e8964a1743f3d4
parent91f242357d0a3c42b0b32db24775949695546769 (diff)
downloadpatches-d2ebdb795d00ae57199491af678ba97a905abc55.tar
patches-d2ebdb795d00ae57199491af678ba97a905abc55.tar.gz
gnu: Add r-rsconnect.
* gnu/packages/cran.scm (r-rsconnect): New variable.
-rw-r--r--gnu/packages/cran.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index c6514c7a94..39d80e08b4 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -20259,3 +20259,32 @@ interesting features. iheatmapr uses the plotly library for interactivity.")
you to manage the R packages your project depends on in an isolated, portable,
and reproducible way.")
(license license:gpl2)))
+
+(define-public r-rsconnect
+ (package
+ (name "r-rsconnect")
+ (version "0.8.16")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "rsconnect" version))
+ (sha256
+ (base32
+ "05ii0p0p7xpf8z0c1594s5q7wpwcs7lmlddrd67s5p2ka5m8qwiz"))))
+ (properties `((upstream-name . "rsconnect")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-curl" ,r-curl)
+ ("r-digest" ,r-digest)
+ ("r-jsonlite" ,r-jsonlite)
+ ("r-openssl" ,r-openssl)
+ ("r-packrat" ,r-packrat)
+ ("r-rstudioapi" ,r-rstudioapi)
+ ("r-yaml" ,r-yaml)))
+ (home-page "https://github.com/rstudio/rsconnect")
+ (synopsis "Deployment interface for R Markdown documents and Shiny applications")
+ (description
+ "This package provides a programmatic deployment interface for RPubs,
+shinyapps.io, and RStudio Connect. Supported content types include R Markdown
+documents, Shiny applications, Plumber APIs, plots, and static web content.")
+ (license license:gpl2)))