summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCyril Roelandt <tipecaml@gmail.com>2013-01-23 21:16:22 +0100
committerLudovic Courtès <ludo@gnu.org>2013-01-24 00:03:43 +0100
commitd192efae07b9eadc31c80fc0b5b4e6e222e30bec (patch)
tree9185349d336658fb1994a8fe948a85e9e9558500
parent21c203a53a617962586ef645b22f80814b05fd65 (diff)
downloadpatches-d192efae07b9eadc31c80fc0b5b4e6e222e30bec.tar
patches-d192efae07b9eadc31c80fc0b5b4e6e222e30bec.tar.gz
gnu: Add OCaml. licenses: Add QPL.
* gnu/packages/ocaml.scm: New file. * Makefile.am (MODULES): Add it. * guix/licenses.scm: New variable.
-rw-r--r--Makefile.am1
-rw-r--r--gnu/packages/ocaml.scm77
-rw-r--r--guix/licenses.scm6
3 files changed, 84 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 54e80cc4ed..f80f166a07 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -108,6 +108,7 @@ MODULES = \
gnu/packages/ncurses.scm \
gnu/packages/netpbm.scm \
gnu/packages/nettle.scm \
+ gnu/packages/ocaml.scm \
gnu/packages/openssl.scm \
gnu/packages/oggvorbis.scm \
gnu/packages/perl.scm \
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
new file mode 100644
index 0000000000..f6bb9f7488
--- /dev/null
+++ b/gnu/packages/ocaml.scm
@@ -0,0 +1,77 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages ocaml)
+ #:use-module (guix licenses)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages perl))
+
+(define-public ocaml
+ (package
+ (name "ocaml")
+ (version "4.00.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://caml.inria.fr/pub/distrib/ocaml-4.00/ocaml-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0yp86napnvbi2jgxr6bk1235bmjdclgzrzgq4mhwv87l7dymr3dl"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:modules ((guix build gnu-build-system)
+ (guix build utils)
+ (srfi srfi-1))
+ #:phases (alist-replace
+ 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; OCaml uses "-prefix <prefix>" rather than the usual
+ ;; "--prefix=<prefix>".
+ (let ((out (assoc-ref outputs "out")))
+ (zero? (system* "./configure" "-prefix" out))))
+ (alist-replace
+ 'build
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; "make" does not do anything, we must use
+ ;; "make world.opt".
+ (zero? (system* "make" "world.opt")))
+ (alist-replace
+ 'check-after-install
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; There does not seem to be a "check" or "test" target.
+ (zero? (system "cd testsuite && make all")))
+ (let ((check (assq-ref %standard-phases 'check)))
+ ;; OCaml assumes that "make install" is run before
+ ;; launching the tests.
+ (alist-cons-after
+ 'install 'check-after-install
+ check
+ (alist-delete 'check %standard-phases))))))))
+ (inputs `(("perl" ,perl)))
+ (home-page "http://caml.inria.fr/")
+ (synopsis "The OCaml programming language")
+ (description
+ "OCaml is a general purpose industrial-strength programming language with
+an emphasis on expressiveness and safety. Developed for more than 20 years at
+Inria it benefits from one of the most advanced type systems and supports
+functional, imperative and object-oriented styles of programming.")
+ (license (list qpl gpl2))))
diff --git a/guix/licenses.scm b/guix/licenses.scm
index 93af865055..c636cc5edf 100644
--- a/guix/licenses.scm
+++ b/guix/licenses.scm
@@ -36,6 +36,7 @@
mpl2.0
openldap2.8 openssl
psfl public-domain
+ qpl
vim
x11
zlib))
@@ -213,6 +214,11 @@ which may be a file:// URI pointing the package's tree."
"http://directory.fsf.org/wiki/License:PublicDomain"
"https://www.gnu.org/licenses/license-list#PublicDomain"))
+(define qpl
+ (license "QPL"
+ "http://directory.fsf.org/wiki/License:QPLv1.0"
+ "http://www.gnu.org/licenses/license-list.html#QPL"))
+
(define vim
(license "Vim"
"http://directory.fsf.org/wiki/License:Vim7.2"