summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Darrington <jmd@gnu.org>2013-12-30 19:33:53 +0100
committerLudovic Courtès <ludo@gnu.org>2013-12-30 23:33:56 +0100
commitbf0018cd87e6a0f706a4298d5c6f62e7ef7f5d16 (patch)
treecf5b3bfdfb44f06173b9a9f0685aa5dd5430ccc2
parent40fed2d836bf974144a0a33acd64a1f3247c6968 (diff)
downloadpatches-bf0018cd87e6a0f706a4298d5c6f62e7ef7f5d16.tar
patches-bf0018cd87e6a0f706a4298d5c6f62e7ef7f5d16.tar.gz
gnu: games: Add new package gnubg
* gnu/packages/games.scm (gnubg): New variable Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/games.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 746ca49fa9..0f5ae4174d 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -22,13 +22,49 @@
#:use-module (guix download)
#:use-module (gnu packages gettext)
#:use-module (gnu packages gl)
+ #:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gtk)
#:use-module (gnu packages guile)
+ #:use-module (gnu packages libcanberra)
+ #:use-module (gnu packages python)
+ #:use-module (gnu packages readline)
#:use-module (gnu packages xorg)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages sqlite)
#:use-module (guix build-system gnu))
+(define-public gnubg
+ (package
+ (name "gnubg")
+ (version "1.02")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://files.gnubg.org/media/sources/gnubg-release-"
+ version ".000-sources." "tar.gz"))
+ (sha256
+ (base32
+ "015mvjk2iw1cg1kxwxfnvp2rxb9cylf6yc39i30fdy414k07zkky"))))
+ (build-system gnu-build-system)
+ (inputs `(("glib" ,glib)
+ ("readline" ,readline)
+ ("gtk+" ,gtk+-2)
+ ("mesa" ,mesa)
+ ("gtkglext" ,gtkglext)
+ ("sqlite" ,sqlite)
+ ("libcanberra" ,libcanberra)))
+ (native-inputs `(("python-2" ,python-2)
+ ("pkg-config" ,pkg-config)))
+ (home-page "https://gnubg.org")
+ (synopsis "Backgammon game")
+ (description "The GNU backgammon application can be used for playing, analyzing and
+teaching the game. It has an advanced evaluation engine based on artificial
+neural networks suitable for both beginners and advanced players. In
+addition to a command-line interface, it also features an attractive, 3D
+representation of the playing board.")
+ (license gpl3+)))
+
(define-public gnubik
(package
(name "gnubik")