summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2019-11-20 13:46:37 +0100
committerLudovic Courtès <ludo@gnu.org>2019-11-26 00:16:54 +0100
commitae8a0184bf5a77f88b95e98d7e042110b082e970 (patch)
tree4c1c2549a438176ca095ee77d8b7fa20cec2c457
parentcd2ce8abae37bc900286e5282ebaa08b88768a54 (diff)
downloadpatches-ae8a0184bf5a77f88b95e98d7e042110b082e970.tar
patches-ae8a0184bf5a77f88b95e98d7e042110b082e970.tar.gz
gnu: Add libdbi.
* gnu/packages/databases.scm (libdbi): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/databases.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index acce540e06..2ccaae205c 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -37,6 +37,7 @@
;;; Copyright © 2019 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2019 Gábor Boskovits <boskovits@gmail.com>
;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
+;;; Copyright © 2019 Guillaume Le Vaillant <glv@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3170,3 +3171,24 @@ NumPy, and other traditional Python scientific computing packages.")
It implements the Python DB API 2.0 specification and includes support for
SQLAlchemy.")
(license license:asl2.0)))
+
+(define-public libdbi
+ (package
+ (name "libdbi")
+ (version "0.9.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/libdbi/libdbi/libdbi-"
+ version "/libdbi-" version ".tar.gz"))
+ (sha256
+ (base32
+ "00s5ra7hdlq25iv23nwf4h1v3kmbiyzx0v9bhggjiii4lpf6ryys"))))
+ (build-system gnu-build-system)
+ (synopsis "Database independent abstraction layer in C")
+ (description
+ "This library implements a database independent abstraction layer in C,
+similar to the DBI/DBD layer in Perl. Writing one generic set of code,
+programmers can leverage the power of multiple databases and multiple
+simultaneous database connections by using this framework.")
+ (home-page "http://libdbi.sourceforge.net/")
+ (license license:lgpl2.1+)))