summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2020-02-26 12:45:54 +0100
committerGuix Patches Tester <>2020-02-26 11:52:10 +0000
commit91f338e5ee8c10c03d410f96b510fe545d34b46d (patch)
tree8367254bad21aa97dabd1c5435f8515dc96146ef
parent8f27be5943c706931395145d7eb1cf600a23acc9 (diff)
downloadpatches-91f338e5ee8c10c03d410f96b510fe545d34b46d.tar
patches-91f338e5ee8c10c03d410f96b510fe545d34b46d.tar.gz
gnu: ghc-doctemplates: Update to 0.8.1.
* gnu/packages/haskell-xyz.scm (ghc-doctemplates): Update to 0.8.1.
-rw-r--r--gnu/packages/haskell-xyz.scm16
1 files changed, 12 insertions, 4 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 03adfdb062..147254c6a9 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -3115,7 +3115,7 @@ Writer monad), where list append quickly becomes too expensive.")
(define-public ghc-doctemplates
(package
(name "ghc-doctemplates")
- (version "0.2.2.1")
+ (version "0.8.1")
(source
(origin
(method url-fetch)
@@ -3124,17 +3124,25 @@ Writer monad), where list append quickly becomes too expensive.")
version ".tar.gz"))
(sha256
(base32
- "1gyckfg3kgvzhxw14i7iwrw0crygvsp86sy53bbr1yn7bxbgn33b"))))
+ "02xysm510m3hbifwb7ngx39wj1ycxjrws4ngnm0d7ywqm9cv1hbb"))))
(build-system haskell-build-system)
(inputs
`(("ghc-aeson" ,ghc-aeson)
("ghc-blaze-markup" ,ghc-blaze-markup)
("ghc-blaze-html" ,ghc-blaze-html)
+ ("ghc-doclayout" ,ghc-doclayout)
+ ("ghc-glob" ,ghc-glob)
+ ("ghc-hsyaml" ,ghc-hsyaml)
("ghc-vector" ,ghc-vector)
("ghc-unordered-containers" ,ghc-unordered-containers)
- ("ghc-scientific" ,ghc-scientific)))
+ ("ghc-safe" ,ghc-safe)
+ ("ghc-scientific" ,ghc-scientific)
+ ("ghc-text-conversions" ,ghc-text-conversions)))
(native-inputs
- `(("ghc-hspec" ,ghc-hspec)))
+ `(("ghc-hspec" ,ghc-hspec)
+ ("ghc-tasty" ,ghc-tasty)
+ ("ghc-tasty-golden" ,ghc-tasty-golden)
+ ("ghc-tasty-hunit" ,ghc-tasty-hunit)))
(home-page "https://github.com/jgm/doctemplates#readme")
(synopsis "Pandoc-style document templates")
(description