summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-02-25 22:07:51 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-02-25 22:49:20 +0100
commit91f242357d0a3c42b0b32db24775949695546769 (patch)
treed8196f5601405158b688af14f07cde8db304c473
parent6616b22b12f682955610bed800e3497e0cdc801b (diff)
downloadpatches-91f242357d0a3c42b0b32db24775949695546769.tar
patches-91f242357d0a3c42b0b32db24775949695546769.tar.gz
gnu: Add r-packrat.
* gnu/packages/cran.scm (r-packrat): New variable.
-rw-r--r--gnu/packages/cran.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 67f14a3b88..c6514c7a94 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -20238,3 +20238,24 @@ data for the same conditions. Interactivity can improve complex heatmaps by
providing tooltips with information about each cell and enabling zooming into
interesting features. iheatmapr uses the plotly library for interactivity.")
(license license:expat)))
+
+(define-public r-packrat
+ (package
+ (name "r-packrat")
+ (version "0.5.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "packrat" version))
+ (sha256
+ (base32
+ "1xy5dd2hrpqa07jfl4s7dsrya05mf36ms74j833scdz0zf89586n"))))
+ (properties `((upstream-name . "packrat")))
+ (build-system r-build-system)
+ (home-page "https://github.com/rstudio/packrat/")
+ (synopsis "Dependency management R projects")
+ (description
+ "This package provides a dependency manager for R projects that allows
+you to manage the R packages your project depends on in an isolated, portable,
+and reproducible way.")
+ (license license:gpl2)))