summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-02-25 22:14:11 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2020-02-26 11:29:27 +0100
commit88dbe39b16a53d1f1fa7b4dad97f10bca22f7d02 (patch)
tree363ed794af1e89f444147774ccede765b22a6a26
parentacba62d9bd80a8fd4e9bd91073db037ba5094d09 (diff)
downloadpatches-88dbe39b16a53d1f1fa7b4dad97f10bca22f7d02.tar
patches-88dbe39b16a53d1f1fa7b4dad97f10bca22f7d02.tar.gz
gnu: Add cl-s-sql.
* gnu/packages/lisp-xyz.scm (sbcl-s-sql, cl-s-sql): New variables.
-rw-r--r--gnu/packages/lisp-xyz.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 736efc79f9..0f5e995afa 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -10827,3 +10827,21 @@ a PostgreSQL server over a socket.")))
(define-public cl-simple-date-postgres-glue
(sbcl-package->cl-source-package sbcl-simple-date-postgres-glue))
+
+(define-public sbcl-s-sql
+ (package
+ (inherit sbcl-simple-date)
+ (name "sbcl-s-sql")
+ (inputs
+ `(("alexandria" ,sbcl-alexandria)
+ ("cl-postgres" ,sbcl-cl-postgres)))
+ (arguments
+ `(#:tests? #f)) ; TODO: Break postmodern circular dependency
+ (synopsis "Lispy DSL for SQL")
+ (description
+ "@code{s-sql} is a Common Lisp library that can be used to compile
+s-expressions to strings of SQL code, escaping any Lisp values inside, and
+doing as much as possible of the work at compile time.")))
+
+(define-public cl-s-sql
+ (sbcl-package->cl-source-package sbcl-s-sql))