summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-02-26 10:12:36 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-02-26 10:12:36 +0100
commit849f6bc20bcb3280b3dee9e5555224d32796b575 (patch)
tree37cac1115e0ec5df414db92934b5f19c1252402f
parentf3de8b6c8a5a7e1404b234de37cac5ef71484c24 (diff)
downloadpatches-849f6bc20bcb3280b3dee9e5555224d32796b575.tar
patches-849f6bc20bcb3280b3dee9e5555224d32796b575.tar.gz
gnu: Add r-rstanarm.
* gnu/packages/cran.scm (r-rstanarm): New variable.
-rw-r--r--gnu/packages/cran.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index e6a350d07e..7ff282bde1 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -20520,3 +20520,44 @@ optimization. In all three cases, automatic differentiation is used to
quickly and accurately evaluate gradients without burdening the user with the
need to derive the partial derivatives.")
(license license:gpl3+)))
+
+(define-public r-rstanarm
+ (package
+ (name "r-rstanarm")
+ (version "2.19.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "rstanarm" version))
+ (sha256
+ (base32
+ "0gxjq8bdlvdd8kn3dhp12xlymdab036r7n12lzmd3xlkl4cnxq3s"))))
+ (properties `((upstream-name . "rstanarm")))
+ (build-system r-build-system)
+ (inputs
+ `(("pandoc" ,ghc-pandoc)
+ ("pandoc-citeproc" ,ghc-pandoc-citeproc)))
+ (propagated-inputs
+ `(("r-bayesplot" ,r-bayesplot)
+ ("r-bh" ,r-bh)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-lme4" ,r-lme4)
+ ("r-loo" ,r-loo)
+ ("r-matrix" ,r-matrix)
+ ("r-nlme" ,r-nlme)
+ ("r-rcpp" ,r-rcpp)
+ ("r-rcppeigen" ,r-rcppeigen)
+ ("r-rcppparallel" ,r-rcppparallel)
+ ("r-rstan" ,r-rstan)
+ ("r-rstantools" ,r-rstantools)
+ ("r-shinystan" ,r-shinystan)
+ ("r-stanheaders" ,r-stanheaders)
+ ("r-survival" ,r-survival)))
+ (home-page "https://mc-stan.org/rstanarm/")
+ (synopsis "Bayesian applied regression modeling via Stan")
+ (description
+ "This package estimates previously compiled regression models using the
+@code{rstan} package, which provides the R interface to the Stan C++ library
+for Bayesian estimation. Users specify models via the customary R syntax with
+a formula and @code{data.frame} plus some additional arguments for priors.")
+ (license license:gpl3+)))