summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-11-11 07:11:09 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-11-11 07:13:01 +0100
commit7a9283a619ac60771abcffdca45d027ff9703c2a (patch)
tree1f26a8357c8c7c1ebb05e88b9d27897923fc6514
parent074ff555abaf587aec927bc897ccde90d7ecafac (diff)
downloadpatches-7a9283a619ac60771abcffdca45d027ff9703c2a.tar
patches-7a9283a619ac60771abcffdca45d027ff9703c2a.tar.gz
gnu: libetonyek: Update to 0.1.7.
* gnu/packages/libreoffice.scm (libetonyek): Update to 0.1.7. [source](patches): Remove. [arguments]<#:phases>: Remove. [native-inputs]: Remove AUTOCONF and AUTOMAKE. * gnu/packages/patches/libetonyek-build-with-mdds-1.2.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/libreoffice.scm26
-rw-r--r--gnu/packages/patches/libetonyek-build-with-mdds-1.2.patch74
3 files changed, 4 insertions, 97 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 69411ec2ba..2be4acc9b9 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -785,7 +785,6 @@ dist_patch_DATA = \
%D%/packages/patches/libcroco-CVE-2017-7960.patch \
%D%/packages/patches/libcroco-CVE-2017-7961.patch \
%D%/packages/patches/libdrm-symbol-check.patch \
- %D%/packages/patches/libetonyek-build-with-mdds-1.2.patch \
%D%/packages/patches/libevent-dns-tests.patch \
%D%/packages/patches/libevent-2.0-CVE-2016-10195.patch \
%D%/packages/patches/libevent-2.0-CVE-2016-10196.patch \
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index f5a6ee4f7e..aa3fb3e549 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -357,33 +357,17 @@ CorelDRAW documents of all versions.")
(define-public libetonyek
(package
(name "libetonyek")
- (version "0.1.6")
+ (version "0.1.7")
(source
(origin
(method url-fetch)
(uri (string-append "http://dev-www.libreoffice.org/src/" name "/"
name "-" version ".tar.xz"))
(sha256 (base32
- "0y60vi1plyq69fqbcjnc0v8mvcjqjsl1ry6rmb3bq3q7j8a2fm6z"))
- (patches
- (cons
- (origin
- (method url-fetch)
- ;; Drop incorrect test that fails with latest liblangtag.
- (uri (string-append "https://cgit.freedesktop.org/libreoffice"
- "/libetonyek/patch/?id="
- "1a20d8ece2ea3e8aa1d319cd88e8a6aa637982f2"))
- (file-name "libetonyek-build-with-liblangtag-0.6.patch")
- (sha256
- (base32
- "0zdyykg3cmq226m54yjhg1fj5200c371h2qgjfna62dxa1jd6m97")))
- (search-patches "libetonyek-build-with-mdds-1.2.patch")))))
+ "1b1lqy6g7flximlv0bp8jbsivyhdp679yj0d0q4jzm968h6y3nv9"))))
(build-system gnu-build-system)
(arguments
- `(#:configure-flags '("--with-mdds=1.2")
- #:phases (modify-phases %standard-phases
- (add-after 'unpack 'autoreconf
- (lambda _ (system* "autoreconf"))))))
+ `(#:configure-flags '("--with-mdds=1.2")))
(native-inputs
`(("cppunit" ,cppunit)
("doxygen" ,doxygen)
@@ -391,9 +375,7 @@ CorelDRAW documents of all versions.")
("gperf" ,gperf)
("liblangtag" ,liblangtag)
("mdds" ,mdds)
- ("pkg-config" ,pkg-config)
- ("autoconf" ,autoconf) ; due to patch
- ("automake" ,automake)))
+ ("pkg-config" ,pkg-config)))
(propagated-inputs ; in Requires or Requires.private field of .pkg
`(("librevenge" ,librevenge)
("libxml2" ,libxml2)))
diff --git a/gnu/packages/patches/libetonyek-build-with-mdds-1.2.patch b/gnu/packages/patches/libetonyek-build-with-mdds-1.2.patch
deleted file mode 100644
index 1ede82ad39..0000000000
--- a/gnu/packages/patches/libetonyek-build-with-mdds-1.2.patch
+++ /dev/null
@@ -1,74 +0,0 @@
-Allow building with mdds 1.2.
-
-Patch taken from upstream commit f6d14b3b510de5c50e45c98fe812a73ba00f3def
-see https://gerrit.libreoffice.org/gitweb?p=libetonyek.git;a=commitdiff;h=f6d14b3b510de5c50e45c98fe812a73ba00f3def
-
-diff --git a/configure.ac b/configure.ac
-index ca4bb07..bb946eb 100644 (file)
---- a/configure.ac
-+++ b/configure.ac
-@@ -24,7 +24,7 @@ AC_LANG([C++])
- # Configure options
- # =================
- AC_ARG_WITH([mdds],
-- AS_HELP_STRING([--with-mdds=1.0|0.x], [Specify which version of mdds to use (1.0 is the default)]),
-+ AS_HELP_STRING([--with-mdds=1.2|1.0|0.x], [Specify which version of mdds to use (1.0 is the default)]),
- [], [with_mdds="1.0"])
-
- # ===========================
-@@ -47,7 +47,7 @@ AC_PROG_SED
-
- AM_MISSING_PROG([GPERF], [gperf])
-
--AS_IF([test "$with_mdds" = "1.0"], [AX_CXX_COMPILE_STDCXX_11([noext])])
-+AS_IF([test "$with_mdds" = "1.0" -o "$with_mdds" = "1.2" ], [AX_CXX_COMPILE_STDCXX_11([noext])])
-
- # ===============
- # Find librevenge
-@@ -138,25 +138,27 @@ AC_SUBST([GLM_CFLAGS])
- # =========
- # Find mdds
- # =========
--AS_IF([test "$with_mdds" = "1.0"], [
-- PKG_CHECK_MODULES([MDDS], [mdds-1.0])
--], [
-- PKG_CHECK_MODULES([MDDS], [mdds])
-- AC_MSG_CHECKING([checking if mdds::flat_segment_tree can store values of any type])
-- old_CPPFLAGS="$CPPFLAGS"
-- CPPFLAGS="$MDDS_CFLAGS $CPPFLAGS"
-- AC_COMPILE_IFELSE([AC_LANG_SOURCE([
-- #include <mdds/flat_segment_tree.hpp>
-- struct Value {};
-- mdds::flat_segment_tree<int, Value> tree(0, 4, Value());
-- ])], [
-- AC_MSG_RESULT([yes])
-- ], [
-- AC_MSG_RESULT([no])
-- AC_MSG_ERROR([please install mdds >= 0.12.1])
-- ])
-- CPPFLAGS="$old_CPPFLAGS"
--])
-+AS_CASE(["$with_mdds"],
-+ ["1.2"], [PKG_CHECK_MODULES([MDDS], [mdds-1.2])],
-+ ["1.0"], [PKG_CHECK_MODULES([MDDS], [mdds-1.0])],
-+ [
-+ PKG_CHECK_MODULES([MDDS], [mdds])
-+ AC_MSG_CHECKING([checking if mdds::flat_segment_tree can store values of any type])
-+ old_CPPFLAGS="$CPPFLAGS"
-+ CPPFLAGS="$MDDS_CFLAGS $CPPFLAGS"
-+ AC_COMPILE_IFELSE([AC_LANG_SOURCE([
-+ #include <mdds/flat_segment_tree.hpp>
-+ struct Value {};
-+ mdds::flat_segment_tree<int, Value> tree(0, 4, Value());
-+ ])], [
-+ AC_MSG_RESULT([yes])
-+ ], [
-+ AC_MSG_RESULT([no])
-+ AC_MSG_ERROR([please install mdds >= 0.12.1])
-+ ])
-+ CPPFLAGS="$old_CPPFLAGS"
-+ ]
-+)
-
- # =================================
- # Libtool/Version Makefile settings