summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-09-10 21:08:12 +0200
committerAndreas Enge <andreas@enge.fr>2013-09-10 21:08:12 +0200
commit73adf220370e12b8788d47ea22ee1975cb9bc752 (patch)
tree209ddf182c2ff5c762204c22dd4b402032431ea8
parente1a264f6fac2f517a2192e07eaae1db600eb8b1d (diff)
downloadpatches-73adf220370e12b8788d47ea22ee1975cb9bc752.tar
patches-73adf220370e12b8788d47ea22ee1975cb9bc752.tar.gz
gnu: Add python-setuptools, python2-setuptools.
* gnu/packages/python.scm (python-setuptools, python2-setuptools): New variables.
-rw-r--r--gnu/packages/python.scm50
1 files changed, 50 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 3ff4da2149..8f65852630 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -247,3 +247,53 @@ etc. ")
(define-public python2-babel
(package-with-python2 python-babel))
+
+(define-public python-setuptools
+ (package
+ (name "python-setuptools")
+ (version "1.1.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://pypi.python.org/packages/source/s/setuptools/setuptools-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0hl9sa5xr9bi2ifq51wy1bawsjv5nzvpbac7m9z1ciz778874csf"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f
+ ;;FIXME: test_sdist_with_utf8_encoded_filename fails in
+ ;; /tmp/nix-build-python2-setuptools-1.1.4.drv-0/setuptools-1.1.4/setuptools/tests/test_sdist.py"
+ ;; line 354
+ ;; The tests pass with Python 2.7.5.
+ #:phases
+ (alist-replace
+ 'install
+ (lambda* (#:key outputs #:allow-other-keys #:rest args)
+ (let* ((install (assoc-ref %standard-phases 'install))
+ (out (assoc-ref outputs "out"))
+ (python (assoc-ref %build-inputs "python"))
+ (python-version (string-take (string-take-right python 5) 3))
+ (path (string-append out "/lib/python" python-version
+ "/site-packages/")))
+ (mkdir-p path)
+ (setenv "PYTHONPATH" path)
+ (apply install args)))
+ %standard-phases)))
+ (home-page "https://pypi.python.org/pypi/setuptools")
+ (synopsis
+ "Library designed to facilitate packaging Python projects")
+ (description
+ "Setuptools is a fully-featured, stable library designed to facilitate
+packaging Python projects, where packaging includes:
+Python package and module definitions,
+distribution package metadata,
+test hooks,
+project installation,
+platform-specific details,
+Python 3 support.")
+ (license psfl)))
+
+(define-public python2-setuptools
+ (package-with-python2 python-setuptools))