summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2012-12-19 23:50:52 +0100
committerLudovic Courtès <ludo@gnu.org>2012-12-20 01:43:38 +0100
commit2ed139c42ca997647412b936c800107fcb5d98ee (patch)
treec42369e35a6fc35092723653fc135116df73d79b
parent5d5c4278394a1fd0341f291e63edca0c200b90cb (diff)
downloadpatches-2ed139c42ca997647412b936c800107fcb5d98ee.tar
patches-2ed139c42ca997647412b936c800107fcb5d98ee.tar.gz
distro: Add mpfrcx and fplll.
* distro/packages/algebra.scm: New file. * Makefile.am (MODULES): Add it.
-rw-r--r--Makefile.am1
-rw-r--r--distro/packages/algebra.scm76
2 files changed, 77 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 3d16a1683d..7a9bc1c713 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -44,6 +44,7 @@ MODULES = \
guix.scm \
distro.scm \
distro/packages/acl.scm \
+ distro/packages/algebra.scm \
distro/packages/attr.scm \
distro/packages/autotools.scm \
distro/packages/base.scm \
diff --git a/distro/packages/algebra.scm b/distro/packages/algebra.scm
new file mode 100644
index 0000000000..3867e754c8
--- /dev/null
+++ b/distro/packages/algebra.scm
@@ -0,0 +1,76 @@
+;;; Guix --- Nix package management from Guile. -*- coding: utf-8 -*-
+;;; Copyright (C) 2012 Andreas Enge <andreas@enge.fr>
+;;;
+;;; This file is part of Guix.
+;;;
+;;; Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (distro packages algebra)
+ #:use-module (distro)
+ #:use-module (distro packages multiprecision)
+ #:use-module (guix licenses)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu))
+
+
+(define-public mpfrcx
+ (package
+ (name "mpfrcx")
+ (version "0.4.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://www.multiprecision.org/mpfrcx/download/mpfrcx-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1rrc75chxyicqjgg5mfhgbz7p9mx1fgh0qlx14a82m25vfhifnd1"))))
+ (build-system gnu-build-system)
+ (inputs `(("gmp" ,gmp)
+ ("mpfr" ,mpfr)
+ ("mpc" ,mpc)))
+ (synopsis "mpfrcx, a library for the arithmetic of univariate polynomials
+over arbitrary precision real or complex numbers")
+ (description
+ "mpfrcx is a library for the arithmetic of univariate polynomials over
+arbitrary precision real (mpfr) or complex (mpc) numbers, without control
+on the rounding. For the time being, only the few functions needed to
+implement the floating point approach to complex multiplication are
+implemented. On the other hand, these comprise asymptotically fast
+multiplication routines such as Toom–Cook and the FFT. ")
+ (license lgpl2.1+)
+ (home-page "http://mpfrcx.multiprecision.org/")))
+
+
+(define-public fplll
+ (package
+ (name "fplll")
+ (version "4.0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://perso.ens-lyon.fr/damien.stehle/fplll/libfplll-"
+ version ".tar.gz"))
+ (sha256 (base32
+ "122bpqdlikshhd7nmq0l5qfc0agyk7x21gvplv1l9hb77l8cy9rw"))))
+ (build-system gnu-build-system)
+ (inputs `(("gmp" ,gmp)
+ ("mpfr" ,mpfr)))
+ (synopsis "fplll, a library for LLL-reduction of euclidean lattices")
+ (description
+ "fplll LLL-reduces euclidean lattices. Since version 3, it can also
+solve the shortest vector problem.")
+ (license lgpl2.1+)
+ (home-page "http://perso.ens-lyon.fr/damien.stehle/fplll/")))