summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-04-09 16:43:13 +0200
committerLudovic Courtès <ludo@gnu.org>2014-04-09 16:43:13 +0200
commit2e4e01eebf3b4b5a40088580ce15078c5a272ef4 (patch)
tree484aa187d7d64f1a05796ab96e486a4a2f8d8f68
parent4ec91959f2d13188894e45f82bf7b8c1c4ea7f4a (diff)
downloadpatches-2e4e01eebf3b4b5a40088580ce15078c5a272ef4.tar
patches-2e4e01eebf3b4b5a40088580ce15078c5a272ef4.tar.gz
gnu: guix: Upgrade to 0.6.
* gnu/packages/package-management.scm (guix): Upgrade to 0.6. * gnu/services/dmd.scm (dmd-configuration-file): Change /var/nix to /var/guix. * gnu/system/vm.scm (operating-system-default-contents): Likewise.
-rw-r--r--gnu/packages/package-management.scm7
-rw-r--r--gnu/services/dmd.scm4
-rw-r--r--gnu/system/vm.scm8
3 files changed, 9 insertions, 10 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index f94f8fc919..e74491a827 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -31,15 +31,14 @@
(define-public guix
(package
(name "guix")
- (version "0.5")
+ (version "0.6")
(source (origin
(method url-fetch)
(uri (string-append "ftp://alpha.gnu.org/gnu/guix/guix-"
version ".tar.gz"))
(sha256
(base32
- "15azhc3lb1m64545q8cs8dzcgjbd2wjxhl6nw0rq6lnvrxz2wjmv"))
- (patches (list (search-patch "guix-test-networking.patch")))))
+ "01xw51wizhsk827w4xp79k2b6dxjaviw04r6rbrb85qdxnwg6k9n"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags (list
diff --git a/gnu/services/dmd.scm b/gnu/services/dmd.scm
index 21719118eb..48e8d5534f 100644
--- a/gnu/services/dmd.scm
+++ b/gnu/services/dmd.scm
@@ -66,8 +66,8 @@ ETC (the name of a directory in the store) on startup."
(not (member file '("." ".."))))))
;; Prevent ETC from being GC'd.
- (rm-f "/var/nix/gcroots/etc-directory")
- (symlink ,etc "/var/nix/gcroots/etc-directory"))
+ (rm-f "/var/guix/gcroots/etc-directory")
+ (symlink ,etc "/var/guix/gcroots/etc-directory"))
(format #t "starting services...~%")
(for-each start ',(append-map service-provision services))))
diff --git a/gnu/system/vm.scm b/gnu/system/vm.scm
index ba4c7607c9..f98a8a70e3 100644
--- a/gnu/system/vm.scm
+++ b/gnu/system/vm.scm
@@ -449,7 +449,7 @@ basic contents of the root file system of OS."
;; XXX: Deal with automatically allocated ids.
(uid (or (user-account-uid user) 0))
(gid (or (user-account-gid user) 0))
- (root (string-append "/var/nix/profiles/per-user/"
+ (root (string-append "/var/guix/profiles/per-user/"
(user-account-name user))))
`((directory ,root ,uid ,gid)
(directory ,home ,uid ,gid))))
@@ -462,14 +462,14 @@ basic contents of the root file system of OS."
(directory "/etc")
(directory "/var/log") ; for dmd
(directory "/var/run/nscd")
- (directory "/var/nix/gcroots")
- ("/var/nix/gcroots/system" -> ,os-dir)
+ (directory "/var/guix/gcroots")
+ ("/var/guix/gcroots/system" -> ,os-dir)
(directory "/run")
("/run/current-system" -> ,profile)
(directory "/bin")
("/bin/sh" -> "/run/current-system/bin/bash")
(directory "/tmp")
- (directory "/var/nix/profiles/per-user/root" 0 0)
+ (directory "/var/guix/profiles/per-user/root" 0 0)
(directory "/root" 0 0) ; an exception
,@(append-map user-directories