summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2020-02-26 12:46:03 +0100
committerGuix Patches Tester <>2020-02-26 11:52:15 +0000
commit2621672b3fda5df9ef4e6b9fd4f70626d1f03e13 (patch)
treeabd4eaf45bb0d5e5cde821c6d93997b58853ab08
parentcab7f744d81d31b7fe6df7f8d9eabcb5161570a0 (diff)
downloadpatches-2621672b3fda5df9ef4e6b9fd4f70626d1f03e13.tar
patches-2621672b3fda5df9ef4e6b9fd4f70626d1f03e13.tar.gz
gnu: ghc-haddock-library: Update to 1.8.0.
* gnu/packages/haskell-xyz.scm (ghc-haddock-library): Update to 1.8.0.
-rw-r--r--gnu/packages/haskell-xyz.scm19
1 files changed, 4 insertions, 15 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index ab50a0381b..832288523b 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -4841,7 +4841,7 @@ documentation-generation tool for Haskell libraries.")
(define-public ghc-haddock-library
(package
(name "ghc-haddock-library")
- (version "1.7.0")
+ (version "1.8.0")
(source
(origin
(method url-fetch)
@@ -4851,23 +4851,12 @@ documentation-generation tool for Haskell libraries.")
".tar.gz"))
(sha256
(base32
- "04fhcjk0pvsaqvsgp2w06cv2qvshq1xs1bwc157q4lmkgr57khp7"))))
+ "15xpv29yh3kb9qq9gmws2l8m64i7phvf47y08vxc2j55101sg4vh"))))
(build-system haskell-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- ;; Since there is no revised Cabal file upstream, we have to
- ;; patch it manually.
- (add-before 'configure 'relax-test-suite-dependencies
- (lambda _
- (substitute* "haddock-library.cabal"
- (("hspec\\s*>= 2.4.4 && < 2.6") "hspec")
- (("QuickCheck\\s*\\^>= 2.11") "QuickCheck"))
- #t)))))
(native-inputs
- `(("ghc-base-compat" ,ghc-base-compat)
+ `(("ghc-base-compat" ,ghc-base-compat-0.11)
("ghc-hspec" ,ghc-hspec)
- ("ghc-optparse-applicative" ,ghc-optparse-applicative)
+ ("ghc-optparse-applicative" ,ghc-optparse-applicative-0.15)
("ghc-quickcheck" ,ghc-quickcheck)
("ghc-tree-diff" ,ghc-tree-diff)
("hspec-discover" ,hspec-discover)))