summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-07-25 18:59:38 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-07-25 21:59:07 +0200
commit12ea2571221fc08b961c9fd38420648126ac6674 (patch)
tree0e2733a2c67229c8f1e7920f6851112efec04928
parentb07aea69dd1d25dbc7f0d5ad28238f16a346352e (diff)
downloadpatches-12ea2571221fc08b961c9fd38420648126ac6674.tar
patches-12ea2571221fc08b961c9fd38420648126ac6674.tar.gz
gnu: clusterssh: Don't propagate xterm.
* gnu/packages/admin.scm (clusterssh)[arguments]: Add ‘refer-to-inputs’ and ‘delete-failing-tests’ phases. [inputs]: Move xterm to here… [propagated-inputs]: …from here.
-rw-r--r--gnu/packages/admin.scm24
1 files changed, 22 insertions, 2 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 580131325a..42dc4396eb 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -913,6 +913,25 @@ by bandwidth they use.")
(base32
"0rmk2p3f2wz1h092anidjclh212rv3gxyk0c641qk3frlrjnw6mp"))))
(build-system perl-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'refer-to-inputs
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* (list "lib/App/ClusterSSH/Config.pm"
+ "t/15config.t")
+ (("xterm")
+ (which "xterm")))
+ #t))
+ (add-before 'check 'delete-failing-tests
+ (lambda _
+ ;; This checks whether all code is nicely formatted. The above
+ ;; ‘refer-to-inputs’ phase breaks this pedantry, so disable it.
+ (delete-file "t/perltidy.t")
+ ;; Update the manifest so t/manifest.t happily passes.
+ (substitute* "MANIFEST"
+ (("t/perltidy.t\n") ""))
+ #t)))))
(native-inputs
`(("perl-cpan-changes" ,perl-cpan-changes)
("perl-file-slurp" ,perl-file-slurp)
@@ -926,9 +945,10 @@ by bandwidth they use.")
("perl-test-pod-coverage" ,perl-test-pod-coverage)
("perl-test-trap" ,perl-test-trap)
("perltidy" ,perltidy)))
+ (inputs
+ `(("xterm" ,xterm)))
(propagated-inputs
- `(("xterm" ,xterm)
- ("perl-exception-class" ,perl-exception-class)
+ `(("perl-exception-class" ,perl-exception-class)
("perl-sort-naturally" ,perl-sort-naturally)
("perl-tk" ,perl-tk)
("perl-try-tiny" ,perl-try-tiny)