summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorValentin Ignatev <valentignatev@gmail.com>2020-01-19 20:02:39 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-02-23 22:23:11 +0200
commitc2b63428f62bf90830a0f627dabf4fe9515bdcd9 (patch)
tree91ff19471dfc7fd4d25091548b5ce4b6a709c9ed
parent881bb7335519ed05c19977784b6073753eeb84ad (diff)
downloadpatches-c2b63428f62bf90830a0f627dabf4fe9515bdcd9.tar
patches-c2b63428f62bf90830a0f627dabf4fe9515bdcd9.tar.gz
gnu: Add rust-stb-truetype-0.3.
* gnu/packages/crates-io.scm (rust-stb-truetype-0.3): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/crates-io.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 6ecac751f3..fca70bde86 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -13600,6 +13600,34 @@ deeply recursive algorithms that may accidentally blow the stack.")
are met.")
(license (list license:expat license:asl2.0))))
+(define-public rust-stb-truetype-0.3
+ (package
+ (name "rust-stb-truetype")
+ (version "0.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "stb_truetype" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0lgvnh3ma6cz811bk8imj45djz76zs47b8327sgnmik2x03nnyzp"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:tests? #f ; tests not included in release
+ #:cargo-inputs
+ (("rust-byteorder" ,rust-byteorder-1.3)
+ ("rust-libm" ,rust-libm-0.2))
+ #:cargo-development-inputs
+ (("rust-approx" ,rust-approx-0.3))))
+ (home-page "https://gitlab.redox-os.org/redox-os/stb_truetype-rs")
+ (synopsis "Translation of the font loading code to Rust")
+ (description
+ "This package provides a straight translation of the font loading code
+in @code{stb_truetype.h} from C to Rust.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-stdweb-0.4
(package
(name "rust-stdweb")