summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorValentin Ignatev <valentignatev@gmail.com>2020-01-19 15:54:07 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-02-23 17:21:05 +0200
commit8b4f3d7fb6d6e8bbea853a4839cedb5a55b78e68 (patch)
tree31f9bbbb1429c86751256eb2985f972be8379e9c
parentb148b5fa980de3802ac1b9976335daf4d85841c0 (diff)
downloadpatches-8b4f3d7fb6d6e8bbea853a4839cedb5a55b78e68.tar
patches-8b4f3d7fb6d6e8bbea853a4839cedb5a55b78e68.tar.gz
gnu: Add rust-thiserror-impl-1.0.
* gnu/packages/crates-io.scm (rust-thiserror-impl-1.0): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/crates-io.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index ea034f7cc6..6e82f8d874 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -14469,6 +14469,32 @@ handle Unicode characters correctly.")
(properties '((hidden? . #t)))
(license license:expat)))
+(define-public rust-thiserror-impl-1.0
+ (package
+ (name "rust-thiserror-impl")
+ (version "1.0.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "thiserror-impl" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1vxzhb98pm5yrq9mmcz50bgpml35iyx7lwjgi4v89sq7ag92abpb"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-proc-macro2" ,rust-proc-macro2-1.0)
+ ("rust-quote" ,rust-quote-1.0)
+ ("rust-syn" ,rust-syn-1.0))))
+ (home-page "https://github.com/dtolnay/thiserror")
+ (synopsis "Implementation detail of the thiserror crate")
+ (description "This package provides an implementation detail of the
+@code{thiserror} crate.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-thread-id-3.3
(package
(name "rust-thread-id")