summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorValentin Ignatev <valentignatev@gmail.com>2020-01-19 16:14:31 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-02-23 22:23:09 +0200
commit791a8e533115c2b8633d3ab7d2f773dad7494d9b (patch)
tree8dd7e076bde0471da94ba53ee42e3e1a53ca5ed2
parent64bb237eb887c2e0d83f77dde40bc6e593fb03ba (diff)
downloadpatches-791a8e533115c2b8633d3ab7d2f773dad7494d9b.tar
patches-791a8e533115c2b8633d3ab7d2f773dad7494d9b.tar.gz
gnu: Add rust-vte-0.3.
* gnu/packages/crates-io.scm (rust-vte-0.3): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/crates-io.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 7f51308e43..1bbde4342f 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -16287,6 +16287,30 @@ updated when the crate version changes.")
"The uninhabited void type for use in statically impossible cases.")
(license license:expat)))
+(define-public rust-vte-0.3
+ (package
+ (name "rust-vte")
+ (version "0.3.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "vte" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1kz8svnqnxclllsgh0ck20rplw3qzp46b5v30yscnzrgw8vgahjg"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:tests? #f ; tests not included in release
+ #:cargo-inputs
+ (("rust-utf8parse" ,rust-utf8parse-0.1))))
+ (home-page "https://github.com/jwilm/vte")
+ (synopsis "Parser for implementing terminal emulators")
+ (description
+ "This package provides a parser for implementing terminal emulators.")
+ (license (list license:asl2.0 license:expat))))
+
(define-public rust-wait-timeout-0.2
(package
(name "rust-wait-timeout")