summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorValentin Ignatev <valentignatev@gmail.com>2020-01-19 16:09:48 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-02-23 22:23:09 +0200
commit64bb237eb887c2e0d83f77dde40bc6e593fb03ba (patch)
treee59d0667bdec00be4994c438cf8c0b14f99fcc47
parent1063dea4ff8a5106b51de8d6de7e23753403c81e (diff)
downloadpatches-64bb237eb887c2e0d83f77dde40bc6e593fb03ba.tar
patches-64bb237eb887c2e0d83f77dde40bc6e593fb03ba.tar.gz
gnu: Add rust-anyhow-1.0 and rust-thiserror-1.0.
* gnu/packages/crates-io.scm (rust-anyhow-1.0, rust-thiserror-1.0): New variables. Add them together because they have cyclic dependencies on each other. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/crates-io.scm55
1 files changed, 55 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index d6b2663c46..7f51308e43 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -277,6 +277,33 @@ text or blue underlined text, on ANSI terminals.")
(license (list license:asl2.0
license:expat))))
+(define-public rust-anyhow-1.0
+ (package
+ (name "rust-anyhow")
+ (version "1.0.26")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "anyhow" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0g6mzcxyj88k8bv8rr3zx4yczgimqvvgr12n14a29sqj6s1zc9bq"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-development-inputs
+ (("rust-futures" ,rust-futures-0.3)
+ ("rust-rustversion" ,rust-rustversion-1.0)
+ ("rust-thiserror" ,rust-thiserror-1.0)
+ ("rust-trybuild" ,rust-trybuild-1.0))))
+ (home-page "https://github.com/dtolnay/anyhow")
+ (synopsis "Flexible concrete Error type")
+ (description "This package provides a flexible concrete Error type built on
+@code{std::error::Error}.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-approx-0.3
(package
(name "rust-approx")
@@ -14514,6 +14541,34 @@ handle Unicode characters correctly.")
(properties '((hidden? . #t)))
(license license:expat)))
+(define-public rust-thiserror-1.0
+ (package
+ (name "rust-thiserror")
+ (version "1.0.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "thiserror" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0zlp3kzjssl1ndqmn7cipqnyggq4851ghhqj4bfc4fxk2hc7sdbg"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-thiserror-impl" ,rust-thiserror-impl-1.0))
+ #:cargo-development-inputs
+ (("rust-anyhow" ,rust-anyhow-1.0)
+ ("rust-ref-cast" ,rust-ref-cast-1.0)
+ ("rust-rustversion" ,rust-rustversion-1.0)
+ ("rust-trybuild" ,rust-trybuild-1.0))))
+ (home-page "https://github.com/dtolnay/thiserror")
+ (synopsis "derive(Error)")
+ (description "This package provides @code{derive(Error)} in Rust.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-thiserror-impl-1.0
(package
(name "rust-thiserror-impl")