summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-02-21 05:19:27 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-02-21 18:33:40 +0100
commitd5f344c987c8cc7b597e938c22e02edf1c4335f3 (patch)
treed37b2196435d5449067e955199a0d1bbed43161e
parentdd6114dfc59592fb6e28af410a55a5151bc7c589 (diff)
downloadpatches-d5f344c987c8cc7b597e938c22e02edf1c4335f3.tar
patches-d5f344c987c8cc7b597e938c22e02edf1c4335f3.tar.gz
gnu: libreoffice: Fix ‘soffice’ in a pure environment.
* gnu/packages/libreoffice.scm (libreoffice)[arguments]: Refer to grep and coreutils by absolute file name in the soffice launcher script.
-rw-r--r--gnu/packages/libreoffice.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 04477e2082..b2f18984ad 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -1034,6 +1034,14 @@ converting QuarkXPress file format. It supports versions 3.1 to 4.1.")
"solenv/gbuild/platform/unxgcc.mk")
(("/bin/sh") (which "sh")))
+ ;; Use store references for strictly necessary commands,
+ ;; but not for optional tools like ‘gdb’ and ‘valgrind’.
+ (for-each (lambda (command)
+ (substitute* "desktop/scripts/soffice.sh"
+ (((format #f"~a " command))
+ (format #f "~a " (which command)))))
+ (list "dirname" "grep" "uname"))
+
;; GPGME++ headers are installed in a gpgme++ subdirectory, but
;; files in "xmlsecurity/source/gpg/" and elsewhere expect to
;; find them on the include path without a prefix.