summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Hill <jackhill@jackhill.us>2020-02-21 08:20:58 -0600
committerAlex Griffin <a@ajgrf.com>2020-02-21 08:25:45 -0600
commit60d5ad8087161451a009d742c8a2980bebda7e38 (patch)
tree9dd5e6a9277f4f4232b10b8de99716f708384f3e
parenta3f6c410673d86feb524ff76c71295e9212a2d0b (diff)
downloadpatches-60d5ad8087161451a009d742c8a2980bebda7e38.tar
patches-60d5ad8087161451a009d742c8a2980bebda7e38.tar.gz
gnu: gnome-shell-extension-paperwm: Recompile schemas.base-for-series-2959
* gnu/packages/gnome-xyz.scm (gnome-shell-extension-paperwm) [source]: Remove gschemas.compiled in a snippet. [arguments]: Add compile-schemas phase. [native-inputs]: Add glib. Signed-off-by: Alex Griffin <a@ajgrf.com>
-rw-r--r--gnu/packages/gnome-xyz.scm17
1 files changed, 14 insertions, 3 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 06af41aea6..34c331d195 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2019 Alexandros Theodotou <alex@zrythm.org>
;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2020 Alex Griffin <a@ajgrf.com>
+;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -318,13 +319,23 @@ It uses ES6 syntax and claims to be more actively maintained than others.")
(file-name (git-file-name name version))
(sha256
(base32
- "1qry75f696pgmd9yzqvwhq5h6cipin2fvk7h881g29cjcpxim37a"))))
+ "1qry75f696pgmd9yzqvwhq5h6cipin2fvk7h881g29cjcpxim37a"))
+ (snippet
+ '(begin (delete-file "schemas/gschemas.compiled")))))
(build-system copy-build-system)
(arguments
'(#:install-plan
'(("." "share/gnome-shell/extensions/paperwm@hedning:matrix.org"
- #:include-regexp ("\\.js(on)?$" "\\.css$" "\\.ui$" "\\.png$"
- "\\.xml$" "\\.compiled$")))))
+ #:include-regexp ("\\.js(on)?$" "\\.css$" "\\.ui$" "\\.png$" "\\.xml$")))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'install 'compile-schemas
+ (lambda _
+ (with-directory-excursion "schemas"
+ (invoke "make"))
+ #t)))))
+ (native-inputs
+ `(("glib:bin" ,glib "bin"))) ; for glib-compile-schemas
(home-page "https://github.com/paperwm/PaperWM")
(synopsis "Tiled scrollable window management for GNOME Shell")
(description "PaperWM is an experimental GNOME Shell extension providing