summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-02-21 21:20:43 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-02-22 00:16:15 +0100
commit3c4c60fa79aac43aa31c1d27732b067ad3842528 (patch)
treed5949d1a6a0f0d237f8763e89fdf66cddb633426
parent3ef91e15344c6cade77e27d9c0f7167fc0c83632 (diff)
downloadpatches-3c4c60fa79aac43aa31c1d27732b067ad3842528.tar
patches-3c4c60fa79aac43aa31c1d27732b067ad3842528.tar.gz
gnu: bind: Update to 9.16.0.
* gnu/packages/dns.scm (isc-bind): Update to 9.16.0. [inputs]: Add libuv. [native-inputs]: Add pkg-config. Remove net-tools. [arguments]: Remove obsolete --with-openssl= from #:configure-flags.
-rw-r--r--gnu/packages/dns.scm16
1 files changed, 8 insertions, 8 deletions
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index b23a7fc9d5..192761b42e 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -114,32 +114,32 @@ and BOOTP/TFTP for network booting of diskless machines.")
(define-public isc-bind
(package
(name "bind")
- (version "9.14.10")
+ (version "9.16.0")
(source (origin
(method url-fetch)
(uri (string-append
"https://ftp.isc.org/isc/bind9/" version
- "/bind-" version ".tar.gz"))
+ "/bind-" version ".tar.xz"))
(sha256
(base32
- "0nkkc2phkkzwgl922xg41gx5pc5f4safabqslaw3880hwdf8vfaa"))))
+ "0a1f1wrlbnmq79q6s15fny36ip81malg6wlr8acp7amimsyxjjxg"))))
(build-system gnu-build-system)
(outputs `("out" "utils"))
(inputs
;; It would be nice to add GeoIP and gssapi once there are packages.
`(("libcap" ,libcap)
+ ("libuv" ,libuv)
("libxml2" ,libxml2)
("openssl" ,openssl)
("p11-kit" ,p11-kit)
("python" ,python)
("python-ply" ,python-ply)))
- (native-inputs `(("perl" ,perl)
- ("net-tools" ,net-tools)))
+ (native-inputs
+ `(("perl" ,perl)
+ ("pkg-config" ,pkg-config)))
(arguments
`(#:configure-flags
- (list (string-append "--with-openssl="
- (assoc-ref %build-inputs "openssl"))
- (string-append "--with-pkcs11="
+ (list (string-append "--with-pkcs11="
(assoc-ref %build-inputs "p11-kit")))
#:phases
(modify-phases %standard-phases