summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Griffin <a@ajgrf.com>2020-02-19 15:46:55 -0600
committerPierre Neidhardt <mail@ambrevar.xyz>2020-02-21 10:53:12 +0100
commitfb18f32e5a3a80e809e369ec148b5a8a87d10c86 (patch)
tree740d31e273654b16cbd7feb72768ca088cc8d7c2
parent11386e18013711cf1817ba28ac3c1e33aec9ed38 (diff)
downloadpatches-fb18f32e5a3a80e809e369ec148b5a8a87d10c86.tar
patches-fb18f32e5a3a80e809e369ec148b5a8a87d10c86.tar.gz
gnu: Add gnome-shell-extension-paperwm.
* gnu/packages/gnome-xyz.scm (gnome-shell-extension-paperwm): New variable.
-rw-r--r--gnu/packages/gnome-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 7f375fefc5..06af41aea6 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2019 Leo Prikler <leo.prikler@student.tugraz.at>
;;; Copyright © 2019 Alexandros Theodotou <alex@zrythm.org>
;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
+;;; Copyright © 2020 Alex Griffin <a@ajgrf.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21,6 +22,7 @@
(define-module (gnu packages gnome-xyz)
#:use-module (guix build-system trivial)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system copy)
#:use-module (guix git-download)
#:use-module (guix packages)
#:use-module ((guix licenses) #:prefix license:)
@@ -304,6 +306,32 @@ It uses ES6 syntax and claims to be more actively maintained than others.")
(home-page "https://extensions.gnome.org/extension/2182/noannoyance/")
(license license:gpl2)))
+(define-public gnome-shell-extension-paperwm
+ (package
+ (name "gnome-shell-extension-paperwm")
+ (version "34.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/paperwm/PaperWM.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1qry75f696pgmd9yzqvwhq5h6cipin2fvk7h881g29cjcpxim37a"))))
+ (build-system copy-build-system)
+ (arguments
+ '(#:install-plan
+ '(("." "share/gnome-shell/extensions/paperwm@hedning:matrix.org"
+ #:include-regexp ("\\.js(on)?$" "\\.css$" "\\.ui$" "\\.png$"
+ "\\.xml$" "\\.compiled$")))))
+ (home-page "https://github.com/paperwm/PaperWM")
+ (synopsis "Tiled scrollable window management for GNOME Shell")
+ (description "PaperWM is an experimental GNOME Shell extension providing
+scrollable tiling of windows and per monitor workspaces. It's inspired by paper
+notebooks and tiling window managers.")
+ (license license:gpl3)))
+
(define-public numix-theme
(package
(name "numix-theme")