summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-06-25 10:53:19 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-06-26 16:24:58 +0200
commitbb74ea09902cf23950a852fd7357818479f93ee0 (patch)
treeb53a20234d24655d3792a3fda588e0d16cc5b2b2
parent37cb4e5b8ebea5bc097730a0476bab8d19d5a15b (diff)
downloadpatches-bb74ea09902cf23950a852fd7357818479f93ee0.tar
patches-bb74ea09902cf23950a852fd7357818479f93ee0.tar.gz
gnu: Add python-pathlib2.
* gnu/packages/python-xyz.scm (python-pathlib2): New variable.
-rw-r--r--gnu/packages/python-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c94af80e2c..aab7e0c7a3 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4827,6 +4827,29 @@ them as the version argument or in a SCM managed file.")
(define-public python2-setuptools-scm
(package-with-python2 python-setuptools-scm))
+(define-public python-pathlib2
+ (package
+ (name "python-pathlib2")
+ (version "2.3.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pathlib2" version))
+ (sha256
+ (base32
+ "0hpp92vqqgcd8h92msm9slv161b1q160igjwnkf2ag6cx0c96695"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-scandir" ,python-scandir)
+ ("python-six" ,python-six)))
+ (home-page "https://pypi.python.org/pypi/pathlib2/")
+ (synopsis "Object-oriented filesystem paths")
+ (description "The goal of pathlib2 is to provide a backport of the
+standard @code{pathlib} module which tracks the standard library module, so
+all the newest features of the standard @code{pathlib} can be used also on
+older Python versions.")
+ (license license:expat)))
+
(define-public python-pathpy
(package
(name "python-pathpy")