summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2018-12-16 23:51:31 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2018-12-16 23:51:31 +0100
commit4b4ccb45fae08e98746eecbdf08cac57029a44ca (patch)
tree2f215f59d44de68272592ca63e89c8b29e51052d
parent2119cd3a350cb5544418a0e8ac6c7fb6dcbf0a13 (diff)
downloadpatches-4b4ccb45fae08e98746eecbdf08cac57029a44ca.tar
patches-4b4ccb45fae08e98746eecbdf08cac57029a44ca.tar.gz
gnu: mame: Update to 0.204.
* gnu/packages/emulators.scm (mame): Update to 0.204. [arguments]: Add phase to fix compilation error.
-rw-r--r--gnu/packages/emulators.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index 795595e447..991599a394 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -1186,7 +1186,7 @@ play them on systems for which they were never designed!")
(define-public mame
(package
(name "mame")
- (version "0.203")
+ (version "0.204")
(source
(origin
(method git-fetch)
@@ -1196,7 +1196,7 @@ play them on systems for which they were never designed!")
(file-name (git-file-name name version))
(sha256
(base32
- "19ccqc00024fbjyk0k5d9xljhwq7wsrp7phwm2jmn0h77mgdj844"))
+ "0yn63v2f1xlksfnvbxc5p5zpc7ps044m1kf69jhzbfirx953slsi"))
(modules '((guix build utils)))
(snippet
;; Remove bundled libraries.
@@ -1223,6 +1223,14 @@ play them on systems for which they were never designed!")
#:phases
(modify-phases %standard-phases
(delete 'configure)
+ ;; Prevent compilation error: ‘atan’ is not a member of ‘std’. Also
+ ;; fixed upstream in fec1cde5a40e197d4ed4314bf58b9e66e84e1631.
+ (add-after 'unpack 'fix-build
+ (lambda _
+ (substitute* "src/mame/video/xavix.cpp"
+ (("#include \"logmacro.h\"")
+ "#include \"logmacro.h\"\n#include <cmath>"))
+ #t))
(add-after 'build 'build-documentation
(lambda _ (invoke "make" "-C" "docs" "man" "info")))
(replace 'install