summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2020-02-14 11:04:24 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2020-02-21 10:53:12 +0100
commit11386e18013711cf1817ba28ac3c1e33aec9ed38 (patch)
tree5110ea2d45db941931eab2b7ae8dd7529da0f65c
parente90e64049ce160d28d1e8b3014badcc2b214627c (diff)
downloadpatches-11386e18013711cf1817ba28ac3c1e33aec9ed38.tar
patches-11386e18013711cf1817ba28ac3c1e33aec9ed38.tar.gz
gnu: gcide: Use the copy-build-system.
* gnu/packages/dictionaries.scm (gcide2)[build-system]: Use the copy-build-system.
-rw-r--r--gnu/packages/dictionaries.scm22
1 files changed, 4 insertions, 18 deletions
diff --git a/gnu/packages/dictionaries.scm b/gnu/packages/dictionaries.scm
index 6108a0d56c..98b710ab6d 100644
--- a/gnu/packages/dictionaries.scm
+++ b/gnu/packages/dictionaries.scm
@@ -31,6 +31,7 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
#:use-module (guix build-system trivial)
+ #:use-module (guix build-system copy)
#:use-module (gnu packages)
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
@@ -109,25 +110,10 @@ acronyms distributed as an info document.")
(sha256
(base32
"1n3bp91sik66z3ca7mjqbr9nck3hg5ck0c8g84xc0qnfpx5vznh2"))))
- (build-system trivial-build-system)
+ (build-system copy-build-system)
(arguments
- '(#:builder (begin
- (use-modules (guix build utils))
- (let* ((src (assoc-ref %build-inputs "source"))
- (tar (assoc-ref %build-inputs "tar"))
- (xz (assoc-ref %build-inputs "xz"))
- (out (assoc-ref %outputs "out"))
- (datadir (string-append out "/share/gcide")))
- (set-path-environment-variable "PATH" '("bin")
- (list tar xz))
- (mkdir-p datadir)
- (invoke "tar" "-C" datadir
- "--strip-components=1"
- "-xvf" src)))
- #:modules ((guix build utils))))
- (native-inputs
- `(("tar" ,tar)
- ("xz" ,xz)))
+ '(#:install-plan
+ '(("." "share/gcide/" #:exclude ("COPYING")))))
(synopsis "GNU Collaborative International Dictionary of English")
(description
"GCIDE is a free dictionary based on a combination of sources. It can