summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-02-19 18:46:04 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-02-19 23:43:39 +0100
commitbfa3caa2fb1436c4d0e24036a9ea60ccc19aabae (patch)
tree32557a73ef36df45daf3253e386fc732466d1745
parent3ca6c1a720c8a6460470d17ec1b63277583d0996 (diff)
downloadpatches-bfa3caa2fb1436c4d0e24036a9ea60ccc19aabae.tar
patches-bfa3caa2fb1436c4d0e24036a9ea60ccc19aabae.tar.gz
gnu: crypto++: Build in parallel.
* gnu/packages/crypto.scm (crypto++)[arguments]: Make ‘build-shared’ the main ‘build’ phase. Respect MAKE-FLAGS and PARALLEL-JOB-COUNT.
-rw-r--r--gnu/packages/crypto.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index 8d81fa70df..aa65774c78 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -627,10 +627,12 @@ data on your platform, so the seed itself will be as random as possible.
((" -march=native") ""))
#t))
(delete 'configure)
- (add-after 'build 'build-shared
- (lambda _
- ;; By default, only the static library is built.
- (invoke "make" "shared")))
+ (replace 'build
+ ;; By default, only the static library is built.
+ (lambda* (#:key (make-flags '()) #:allow-other-keys)
+ (apply invoke "make" "shared"
+ "-j" (number->string (parallel-job-count))
+ make-flags)))
(add-after 'install 'install-shared-library-links
;; By default, only .so and .so.x.y.z are installed.
;; Create all the ‘intermediates’ expected by dependent packages.