summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2020-02-20 01:18:01 +0100
committerJulien Lepiller <julien@lepiller.eu>2020-02-20 02:09:56 +0100
commit6dde98c3d9e7a0385da57abedd9b41ca733acfc6 (patch)
tree822246ea7079820e6d523bcdfb945f4a9fbde1fa
parent00c967f6a403f06c2e2217a8b0f208ddc89bca4c (diff)
downloadpatches-6dde98c3d9e7a0385da57abedd9b41ca733acfc6.tar
patches-6dde98c3d9e7a0385da57abedd9b41ca733acfc6.tar.gz
gnu: libevent: Split into two outputs.
This removes python and its dependencies from the libevent closure, reducing it from 180MB to 70MB. * gnu/packages/libevent.scm (libevent): Add bin output.
-rw-r--r--gnu/packages/libevent.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/packages/libevent.scm b/gnu/packages/libevent.scm
index 465ed95eb2..338b2afd4e 100644
--- a/gnu/packages/libevent.scm
+++ b/gnu/packages/libevent.scm
@@ -51,6 +51,7 @@
(base32
"0g988zqm45sj1hlhhz4il5z4dpi5dl74hzjwzl4md37a09iaqnx6"))))
(build-system gnu-build-system)
+ (outputs '("out" "bin"))
(arguments
;; This skips some of the tests which fail on armhf and aarch64.
'(#:configure-flags '("--disable-libevent-regress")))