summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2019-07-07 17:59:28 -0700
committerTimothy Sample <samplet@ngyro.com>2019-09-02 23:09:39 -0400
commit21f5b9a9b9a8d30aeeb686febbf59a88a97f4c1b (patch)
tree35ef2d78e1ab7167346b2e4b4aa595486cbf2973
parent55f4c6533656873a21dcea5a7e4e4b1faef22d42 (diff)
downloadpatches-21f5b9a9b9a8d30aeeb686febbf59a88a97f4c1b.tar
patches-21f5b9a9b9a8d30aeeb686febbf59a88a97f4c1b.tar.gz
gnu: Add ghc-process-extras.
* gnu/packages/haskell-xyz.scm (ghc-process-extras): New variable. Signed-off-by: Timothy Sample <samplet@ngyro.com>
-rw-r--r--gnu/packages/haskell-xyz.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index c98e65dcef..940fbe8a6c 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -7756,6 +7756,36 @@ examination.")
"This package provides various primitive memory-related operations.")
(license license:bsd-3)))
+(define-public ghc-process-extras
+ (package
+ (name "ghc-process-extras")
+ (version "0.7.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append
+ "https://hackage.haskell.org/package/process-extras/"
+ "process-extras-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0klqgr37f1z2z6i0a9b0giapmq0p35l5k9kz1p7f0k1597w7agi9"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-data-default" ,ghc-data-default)
+ ("ghc-generic-deriving" ,ghc-generic-deriving)
+ ("ghc-hunit" ,ghc-hunit)
+ ("ghc-listlike" ,ghc-listlike)))
+ (home-page "https://github.com/seereason/process-extras")
+ (synopsis "Extra tools for managing processes")
+ (description "This packages extends
+@url{http://hackage.haskell.org/package/process}. It allows you to read
+process input and output as ByteStrings or Text, or write your own
+ProcessOutput instance. It also provides lazy process input and output,
+and a ProcessMaker class for more flexibility in the process creation
+API.")
+ (license license:expat)))
+
(define-public ghc-profunctors
(package
(name "ghc-profunctors")