summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2014-05-27 10:04:42 -0500
committerEric Bavier <bavier@member.fsf.org>2014-05-27 10:05:33 -0500
commitd1a5439bcbb1da781e08a69a630722af626263d2 (patch)
tree33fc9523dc7f59e906689816d51187b4ddc7f242
parent5a1a4bf6b2cc2a7652d0c9199b22af6297b78f7e (diff)
downloadpatches-d1a5439bcbb1da781e08a69a630722af626263d2.tar
patches-d1a5439bcbb1da781e08a69a630722af626263d2.tar.gz
gnu: Add duplicity.
* gnu/packages/backup.scm: New file. * gnu-system.am: Add it.
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/backup.scm71
2 files changed, 72 insertions, 0 deletions
diff --git a/gnu-system.am b/gnu-system.am
index 242dc2d134..6cd98c6aea 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -36,6 +36,7 @@ GNU_SYSTEM_MODULES = \
gnu/packages/autogen.scm \
gnu/packages/autotools.scm \
gnu/packages/avahi.scm \
+ gnu/packages/backup.scm \
gnu/packages/base.scm \
gnu/packages/bash.scm \
gnu/packages/bdb.scm \
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
new file mode 100644
index 0000000000..574bb11816
--- /dev/null
+++ b/gnu/packages/backup.scm
@@ -0,0 +1,71 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages backup)
+ #:use-module (guix packages)
+ #:use-module (guix licenses)
+ #:use-module (guix download)
+ #:use-module (guix build-system python)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages python)
+ #:use-module (gnu packages gnupg)
+ #:use-module (gnu packages rsync)
+ #:use-module (srfi srfi-1))
+
+(define-public duplicity
+ (package
+ (name "duplicity")
+ (version "0.6.24")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://code.launchpad.net/duplicity/"
+ (string-join (take (string-split version #\.) 2) ".")
+ "-series/" version "/+download/duplicity-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0l14nrhbgkyjgvh339bbhnm6hrdwrjadphq1jmpi0mcgcdbdfh8x"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python2-setuptools" ,python2-setuptools)))
+ (inputs
+ `(("python" ,python-2)
+ ("librsync" ,librsync)
+ ("mock" ,python2-mock) ;for testing
+ ("lockfile" ,python2-lockfile)
+ ("gnupg" ,gnupg-1))) ;gpg executable needed
+ (arguments
+ `(#:python ,python-2 ;setup assumes Python 2
+ #:test-target "test"
+ #:phases (alist-cons-before
+ 'check 'patch-tests
+ (lambda _
+ (substitute* "testing/functional/__init__.py"
+ (("/bin/sh") (which "sh"))))
+ %standard-phases)))
+ (home-page "http://duplicity.nongnu.org/index.html")
+ (synopsis "Encrypted backup using rsync algorithm")
+ (description
+ "Duplicity backs up directories by producing encrypted tar-format volumes
+and uploading them to a remote or local file server. Because duplicity uses
+librsync, the incremental archives are space efficient and only record the
+parts of files that have changed since the last backup. Because duplicity
+uses GnuPG to encrypt and/or sign these archives, they will be safe from
+spying and/or modification by the server.")
+ (license gpl2+)))