summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorValentin Ignatev <valentignatev@gmail.com>2020-01-18 21:07:55 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-02-19 09:49:28 +0200
commitf8d773f43352a3306f99b5ea8253407b4e32e4d8 (patch)
tree49965942624a8912e20d9ce4324284f8779a7845
parent84eb24b68a39cc10609f93f60d84f34aedfc6129 (diff)
downloadpatches-f8d773f43352a3306f99b5ea8253407b4e32e4d8.tar
patches-f8d773f43352a3306f99b5ea8253407b4e32e4d8.tar.gz
gnu: rust-nom-4.2: Fix dependencies
* gnu/packages/crates-io.scm (rust-nom-4.2)[arguments]: Remove rust-lexical-core-0.4, add rust-version-check-0.1 to cargo-inputs. Remove rust-doc-comment-0.3, rust-version-check-0.9 from cargo-development-inputs. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/crates-io.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 07679bc0e3..ab7909306e 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -7904,14 +7904,12 @@ implementation (which is unstable / requires nightly).")
`(#:skip-build? #t
#:cargo-inputs
(("rust-lazy-static" ,rust-lazy-static-1)
- ("rust-lexical-core" ,rust-lexical-core-0.4)
("rust-memchr" ,rust-memchr-2.2)
- ("rust-regex" ,rust-regex-1.1))
+ ("rust-regex" ,rust-regex-1.1)
+ ("rust-version-check" ,rust-version-check-0.1))
#:cargo-development-inputs
(("rust-criterion" ,rust-criterion-0.2)
- ("rust-doc-comment" ,rust-doc-comment-0.3)
- ("rust-jemallocator" ,rust-jemallocator-0.3)
- ("rust-version-check" ,rust-version-check-0.9))))
+ ("rust-jemallocator" ,rust-jemallocator-0.1))))
(home-page "https://github.com/Geal/nom")
(synopsis
"Byte-oriented, zero-copy, parser combinators library")