summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-02-17 21:57:19 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-02-17 23:07:43 +0200
commitb18c509694ecc45f38f55d8f962c4258e4e9e43b (patch)
tree22f20d336db04811296e9cd1eb9d2b1b27c19f9d
parent91aee318a407b67893432a9d76f26eb9134769ac (diff)
downloadpatches-b18c509694ecc45f38f55d8f962c4258e4e9e43b.tar
patches-b18c509694ecc45f38f55d8f962c4258e4e9e43b.tar.gz
gnu: rust-stdweb-internal-macros-0.2: Update to 0.2.9.
* gnu/packages/crates-io.scm (rust-stdweb-internal-macros-0.2): Update to 0.2.9. [arguments]: Don't skip build. Replace rust-proc-macro2-0.4 with 1.0, rust-syn-0.15 with 1.0 in cargo-inputs. [description]: Texify.
-rw-r--r--gnu/packages/crates-io.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 47350d431b..a08eaf063c 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -12485,7 +12485,7 @@ you to define custom reference types outside of the @code{stdweb} library.")
(define-public rust-stdweb-internal-macros-0.2
(package
(name "rust-stdweb-internal-macros")
- (version "0.2.7")
+ (version "0.2.9")
(source
(origin
(method url-fetch)
@@ -12494,23 +12494,22 @@ you to define custom reference types outside of the @code{stdweb} library.")
(string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1yjrmkc6sb1035avic383pa3avk2s9k3n17yjcza8yb9nw47v3z6"))))
+ "049fq8fl5ny9l5if2qv7kxwng7g6ns95h4fbm3zx360dmpv5zyjq"))))
(build-system cargo-build-system)
(arguments
- `(#:skip-build? #t
- #:cargo-inputs
+ `(#:cargo-inputs
(("rust-base-x" ,rust-base-x-0.2)
- ("rust-proc-macro2" ,rust-proc-macro2-0.4)
+ ("rust-proc-macro2" ,rust-proc-macro2-1.0)
("rust-quote" ,rust-quote-1.0)
("rust-serde" ,rust-serde-1.0)
("rust-serde-derive" ,rust-serde-derive-1.0)
("rust-serde-json" ,rust-serde-json-1.0)
("rust-sha1" ,rust-sha1-0.6)
- ("rust-syn" ,rust-syn-0.15))))
+ ("rust-syn" ,rust-syn-1.0))))
(home-page "https://github.com/koute/stdweb")
(synopsis "Internal procedural macros for the stdweb crate")
(description
- "Internal procedural macros for the stdweb crate.")
+ "Internal procedural macros for the @code{stdweb} crate.")
(license (list license:expat license:asl2.0))))
(define-public rust-stdweb-internal-runtime-0.1