summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-02-18 18:09:17 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-02-18 18:25:29 +0100
commita894ca327b8d05cc16d4657ea3e3af167f55a37b (patch)
tree110673f1cf3b0dd8eb0ca408eefc7c60386b123b
parentd462bf0e4941ee73881d3a449081c4347e7c966c (diff)
downloadpatches-a894ca327b8d05cc16d4657ea3e3af167f55a37b.tar
patches-a894ca327b8d05cc16d4657ea3e3af167f55a37b.tar.gz
gnu: cvs-fast-export: Use non-native Python 3.
* gnu/packages/version-control.scm (cvs-fast-export)[native-inputs]: Remove python-2. [inputs]: Add python-wrapper.
-rw-r--r--gnu/packages/version-control.scm14
1 files changed, 8 insertions, 6 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index c5d99b6b64..24a7e3590a 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1580,12 +1580,14 @@ RCS, PRCS, and Aegis packages.")
#:parallel-build? #f ; parallel a2x commands fail spectacularly
#:make-flags
(list "CC=gcc" (string-append "prefix?=" (assoc-ref %outputs "out")))))
- (inputs `(("git" ,git)))
- (native-inputs `(("asciidoc" ,asciidoc)
- ;; These are needed for the tests.
- ("cvs" ,cvs)
- ("python" ,python-2)
- ("rcs" ,rcs)))
+ (inputs
+ `(("git" ,git)
+ ("python" ,python-wrapper)))
+ (native-inputs
+ `(("asciidoc" ,asciidoc)
+ ;; These are needed for the tests.
+ ("cvs" ,cvs)
+ ("rcs" ,rcs)))
(home-page "http://www.catb.org/esr/cvs-fast-export/")
(synopsis "Export an RCS or CVS history as a fast-import stream")
(description "This program analyzes a collection of RCS files in a CVS