summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2020-02-18 11:44:16 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2020-02-18 17:11:43 +0100
commita0d19554cb4c7809d34fd05578bb85c92ce1bf4d (patch)
treef2fa81e5b5d17a5b3a8e626ff7a3fafd5d6da30d
parent38655d7b88ae9d82208e5750480c9b91dd9dda8b (diff)
downloadpatches-a0d19554cb4c7809d34fd05578bb85c92ce1bf4d.tar
patches-a0d19554cb4c7809d34fd05578bb85c92ce1bf4d.tar.gz
gnu: guile-ssh: Fix cross-compilation.
* gnu/packages/ssh.scm (guile-ssh)[native-inputs]: Add guile.
-rw-r--r--gnu/packages/ssh.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 4b1e02be16..72b7c745f9 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -291,7 +291,8 @@ Additionally, various channel-specific options can be negotiated.")
("libtool" ,libtool)
("texinfo" ,texinfo)
("pkg-config" ,pkg-config)
- ("which" ,which)))
+ ("which" ,which)
+ ("guile" ,guile-2.2))) ;needed when cross-compiling.
(inputs `(("guile" ,guile-2.2)
("libssh" ,libssh)
("libgcrypt" ,libgcrypt)))
@@ -306,6 +307,9 @@ libssh library.")
(package
(inherit guile-ssh)
(name "guile2.0-ssh")
+ (native-inputs
+ `(("guile" ,guile-2.0) ;needed when cross-compiling.
+ ,@(alist-delete "guile" (package-native-inputs guile-ssh))))
(inputs `(("guile" ,guile-2.0)
,@(alist-delete "guile" (package-inputs guile-ssh))))))
@@ -313,6 +317,9 @@ libssh library.")
(package
(inherit guile-ssh)
(name "guile3.0-ssh")
+ (native-inputs
+ `(("guile" ,guile-next) ;needed when cross-compiling.
+ ,@(alist-delete "guile" (package-native-inputs guile-ssh))))
(inputs `(("guile" ,guile-next)
,@(alist-delete "guile" (package-inputs guile-ssh))))))