summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2020-02-18 11:47:32 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2020-02-18 11:47:32 +0100
commit85e887ddc7037dcf285025ba8eecc0946a1b74fb (patch)
treebea3c63eecca9c553d0f003982c337018726b657
parent10cdf1408047f16e02d097c4cd23c8efcddb5814 (diff)
downloadpatches-85e887ddc7037dcf285025ba8eecc0946a1b74fb.tar
patches-85e887ddc7037dcf285025ba8eecc0946a1b74fb.tar.gz
gnu: guile-git: Fix cross-compilation.
* gnu/packages/guile.scm (guile-git)[native-inputs]: Add guile and guile-bytestructures.
-rw-r--r--gnu/packages/guile.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 289158ea1b..a5466f8672 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -654,7 +654,9 @@ type system, elevating types to first-class status.")
"0c5i3d16hp7gp9rd78vk9zc45js8bphf92m4lbb5gyi4l1yl7kkm"))))
(build-system gnu-build-system)
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ `(("pkg-config" ,pkg-config)
+ ("guile" ,guile-2.2)
+ ("guile-bytestructures" ,guile-bytestructures)))
(inputs
`(("guile" ,guile-2.2)
("libgit2" ,libgit2)))