summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-29 15:39:55 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-29 17:13:45 +0100
commit2a72ef561b53b69210df2c1562f9d8ced35adabd (patch)
tree7375e8aae50917f787c91f6088118c67945e33b3
parent229f97c37aef0f50d144524275315fd36cd5973a (diff)
downloadpatches-2a72ef561b53b69210df2c1562f9d8ced35adabd.tar
patches-2a72ef561b53b69210df2c1562f9d8ced35adabd.tar.gz
gnu: Add r-motifstack.
* gnu/packages/bioconductor.scm (r-motifstack): New variable.
-rw-r--r--gnu/packages/bioconductor.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 63a1c9923c..af2d7ce335 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -3240,3 +3240,34 @@ motifs. It makes use of STAMP for comparing a set of motifs to a given
database (e.g. JASPAR). It can also be used to visualize motifs, motif
distributions, modules and filter motifs.")
(license license:gpl2)))
+
+(define-public r-motifstack
+ (package
+ (name "r-motifstack")
+ (version "1.26.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "motifStack" version))
+ (sha256
+ (base32
+ "1c4w39ilc4ca4wgi1b6iypadkbxvqjw7k2br0d7q03niw9qjkhxf"))))
+ (properties `((upstream-name . "motifStack")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-ade4" ,r-ade4)
+ ("r-biostrings" ,r-biostrings)
+ ("r-grimport" ,r-grimport)
+ ("r-htmlwidgets" ,r-htmlwidgets)
+ ("r-motiv" ,r-motiv)
+ ("r-scales" ,r-scales)
+ ("r-xml" ,r-xml)))
+ (home-page "https://bioconductor.org/packages/motifStack/")
+ (synopsis "Plot stacked logos for DNA, RNA and amino acid sequences")
+ (description
+ "The motifStack package is designed for graphic representation of
+multiple motifs with different similarity scores. It works with both DNA/RNA
+sequence motifs and amino acid sequence motifs. In addition, it provides the
+flexibility for users to customize the graphic parameters such as the font
+type and symbol colors.")
+ (license license:gpl2+)))