summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-04-12 14:45:08 +0200
committerLudovic Courtès <ludo@gnu.org>2015-04-12 14:45:08 +0200
commit260b07a7d0e67bd9a22259192b6e4222e468b0d9 (patch)
tree106bfab9ebb6348753d769871f25cc2ed144030b
parent13cc689ae8f5d40d124e756cc64b32c41bc1b8d6 (diff)
downloadpatches-260b07a7d0e67bd9a22259192b6e4222e468b0d9.tar
patches-260b07a7d0e67bd9a22259192b6e4222e468b0d9.tar.gz
gnu: gtk+: Pass --with-html-dir=$doc.
Fixes a regression introduced in 6b1f238. * gnu/packages/gtk.scm (gtk+)[arguments]: Add #:configure-flags.
-rw-r--r--gnu/packages/gtk.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index cd36ebfd65..cd54cfc5b9 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -505,7 +505,12 @@ application suites.")
("python-wrapper" ,python-wrapper)
("xorg-server" ,xorg-server)))
(arguments
- `(#:phases
+ `(;; 47 MiB goes to "out" (24 of which is locale data!), and 26 MiB goes
+ ;; to "doc".
+ #:configure-flags (list (string-append "--with-html-dir="
+ (assoc-ref %outputs "doc")
+ "/share/gtk-doc/html"))
+ #:phases
(alist-cons-before
'configure 'pre-configure
(lambda _