summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-02-17 22:44:33 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-02-18 01:26:06 +0100
commit1943a258bb8f12a7f9cd8313ef4ea6da8af60299 (patch)
treed03f3e2e779ac93d8801144903218e170989506d
parent949e214509d2c48dba4d3833dc7b70f24b1e6b5e (diff)
downloadpatches-1943a258bb8f12a7f9cd8313ef4ea6da8af60299.tar
patches-1943a258bb8f12a7f9cd8313ef4ea6da8af60299.tar.gz
gnu: connman: Update to 1.38.
* gnu/packages/connman.scm (connman): Update to 1.38. [inputs]: Add libmnl.
-rw-r--r--gnu/packages/connman.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/connman.scm b/gnu/packages/connman.scm
index 0098cb8dc7..5f17a0ea95 100644
--- a/gnu/packages/connman.scm
+++ b/gnu/packages/connman.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -44,14 +44,14 @@
(define-public connman
(package
(name "connman")
- (version "1.37")
+ (version "1.38")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://kernel.org/linux/network/connman/"
"connman-" version ".tar.xz"))
(sha256
- (base32 "05kfjiqhqfmbbwc4snnyvi5hc4zxanac62f6gcwaf5mvn0z9pqkc"))))
+ (base32 "0awkqigvhwwxiapw0x6yd4whl465ka8a4al0v2pcqy9ggjlsqc6b"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
@@ -74,6 +74,7 @@
("glib" ,glib)
("gnutls" ,gnutls)
("iptables" ,iptables)
+ ("libmnl" ,libmnl)
("readline" ,readline)
;; These inputs are needed for connman to include the interface to
;; these technologies so IF they are installed they can be used.