summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-02-16 17:08:38 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-02-16 22:46:38 +0100
commitfbc2c04e207815d88d6506eaeab15c6cb5e59bce (patch)
treeea014ce862c024b67b558266e0b32007d87dec60
parent338ae8eb366003c6e66ef1bfec0bbed498a386d0 (diff)
downloadpatches-fbc2c04e207815d88d6506eaeab15c6cb5e59bce.tar
patches-fbc2c04e207815d88d6506eaeab15c6cb5e59bce.tar.gz
gnu: lttoolbox: Update to 3.5.1.
* gnu/packages/dictionaries.scm (lttoolbox): Update to 3.5.1. [arguments]: Replace ‘bootstrap’ phase. [native-inputs]: Add autoconf, automake, and libtool.
-rw-r--r--gnu/packages/dictionaries.scm18
1 files changed, 14 insertions, 4 deletions
diff --git a/gnu/packages/dictionaries.scm b/gnu/packages/dictionaries.scm
index ef239378d0..3e7710537c 100644
--- a/gnu/packages/dictionaries.scm
+++ b/gnu/packages/dictionaries.scm
@@ -312,7 +312,7 @@ translation engines from your terminal.")
(define-public lttoolbox
(package
(name "lttoolbox")
- (version "3.5.0")
+ (version "3.5.1")
(source
(origin
(method url-fetch)
@@ -320,14 +320,24 @@ translation engines from your terminal.")
"https://github.com/apertium/lttoolbox/releases/download/v"
version "/lttoolbox-" version ".tar.gz"))
(sha256
- (base32
- "08y6pf1hl7prwygy1g8h6ndqww18pmb9f3r5988q0pcrp8w6xz6b"))
+ (base32 "14yyrkzyqlsrii3v3ggg4dyvwlrcqcqc0aprphz5781a44jsrcwz"))
(file-name (string-append name "-" version ".tar.gz"))))
(build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'bootstrap
+ ;; The included ./autogen.sh unconditionally runs ./configure before
+ ;; its shebangs have been patched.
+ (lambda _
+ (invoke "autoreconf" "-vfi"))))))
(inputs
`(("libxml2" ,libxml2)))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)))
(home-page "http://wiki.apertium.org/wiki/Lttoolbox")
(synopsis "Lexical processing toolbox")
(description "Lttoolbox is a toolbox for lexical processing, morphological