summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Smith <robertsmith@posteo.net>2020-02-14 17:59:18 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-02-17 10:11:18 +0100
commitdb9979e7f9a8f94885ce593d78fe02de6dd71717 (patch)
tree0074dbc71ee81189defe9eb7ce1979a11011aa2d
parentf98e83a17fa30587520e858231ec9c61f3624ecd (diff)
downloadpatches-db9979e7f9a8f94885ce593d78fe02de6dd71717.tar
patches-db9979e7f9a8f94885ce593d78fe02de6dd71717.tar.gz
* gnu/packages/emacs-xyz.scm (emacs-persist): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 5c4db0f7b0..f632bdd6ff 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -58,6 +58,7 @@
;;; Copyright © 2019 Leo Prikler <leo.prikler@student.tugraz.at>
;;; Copyright © 2019 David Wilson <david@daviwil.com>
;;; Copyright © 2020 Paul Garlick <pgarlick@tourbillion-technology.com>
+;;; Copyright © 2020 Robert Smith <robertsmith@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21455,3 +21456,24 @@ Flyspell's on-the-fly spell checking and extends these checks to also detect
language. Auto-dictionary then sets @code{ispell-dictionary} to use the
detected language.")
(license license:gpl2+)))
+
+(define-public emacs-persist
+ (package
+ (name "emacs-persist")
+ (version "0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://elpa.gnu.org/packages/"
+ "persist-" version ".tar"))
+ (sha256
+ (base32 "0gpxy41qawzss2526j9a7lys60vqma1lvamn4bfabwza7gfhac0q"))))
+ (build-system emacs-build-system)
+ (home-page "http://elpa.gnu.org/packages/persist.html")
+ (synopsis "Persist variables between Emacs sessions")
+ (description
+ "This package provides variables which persist across sessions.
+Values are stored in a directory in @code{user-emacs-directory}, using
+one file per value. This makes it easy to delete or remove unused
+variables.")
+ (license license:gpl3+)))