summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorsirgazil <sirgazil@zoho.com>2020-02-14 13:53:23 -0500
committerJakub Kądziołka <kuba@kadziolka.net>2020-02-14 23:24:32 +0100
commitda8ca4c3fc2ac36977e3190bb05802c487619e8c (patch)
treea1e3509262b8ce0b8b7069666c395a05961f5a56
parent9e89b4196605457cff6ca14b21f86c7b25a22671 (diff)
downloadpatches-da8ca4c3fc2ac36977e3190bb05802c487619e8c.tar
patches-da8ca4c3fc2ac36977e3190bb05802c487619e8c.tar.gz
gnu: Add python-fuzzywuzzy.
* gnu/packages/python-xyz.scm (python-fuzzywuzzy, python2-fuzzywuzzy): New variables. Signed-off-by: Jakub Kądziołka <kuba@kadziolka.net>
-rw-r--r--gnu/packages/python-xyz.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ca559ca00a..aeea4df12a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -69,6 +69,7 @@
;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
;;; Copyright © 2019 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
+;;; Copyright © 2020 sirgazil <sirgazil@zoho.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -17541,3 +17542,31 @@ extensive support of PNG features. It can also read and write Netpbm PAM
files, with a focus on its use as an intermediate format for implementing
custom PNG processing.")
(license license:expat)))
+
+(define-public python-fuzzywuzzy
+ (package
+ (name "python-fuzzywuzzy")
+ (version "0.18.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "fuzzywuzzy" version))
+ (sha256
+ (base32
+ "1s00zn75y2dkxgnbw8kl8dw4p1mc77cv78fwfa4yb0274s96w0a5"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-hypothesis" ,python-hypothesis)
+ ("python-pycodestyle" ,python-pycodestyle)
+ ("python-pytest" ,python-pytest)))
+ (propagated-inputs
+ `(("python-levenshtein" ,python-levenshtein)))
+ (home-page "https://github.com/seatgeek/fuzzywuzzy")
+ (synopsis "Fuzzy string matching in python")
+ (description "Approximate string matching using
+@emph{Levenshtein Distance} to calculate the differences between
+sequences.")
+ (license license:gpl2)))
+
+(define-public python2-fuzzywuzzy
+ (package-with-python2 python-fuzzywuzzy))